Remove All Ads from XDA
Honor 9 Lite

Help Me Unbrick

7 posts
Thanks Meter: 1
By slownis, Junior Member on 12th June 2014, 09:15 PM
Post Reply Email Thread
Sprint Galaxy S3. History of the device is, I updated to 4.3 OTA, rooted using saferoot, odin'ed to stock 4.3 to get root, flashed philz, started getting update nag for 4.4 so I followed a guide and installed something in my system directory that blocks it. It seemed to work fine for a bit. Then one day I picked up the phone off my nightstand and it was bricked. I had just checked my email on it a few minutes earlier.

if I put in the battery, the phone autoboots, but all i get is the Samsung logo for about a second and then it shuts down, completely dead (buttons don't do anything) until I remove the battery again and reset the device by hold power for a few seconds with no battery inserted.

My class 10 samsung 16 GB SD card that was in the phone seems to be dead now too, I couldn't read anything when I put it in another computer.

I can boot into philz recovery by holding power, vol up, and home button, while sliding in the battery.

I can't boot into download mode using this method. After holding power, vol down, and home button while sliding in the batter, it attempts to go to download mode, but again shuts down dead like what happens on a normal boot.

I got the usb jig and it doesn't help me at all.

I got another 16GB class 10 SD and tried this method:

using the debrick image from here:

and that doesn't seem to work. Putting in the debrick SD card seems to make no difference.

Is there a way to use philz to recover my phone? Is there a different debrick image that would work better for me?
13th June 2014, 10:24 PM |#2  
OP Junior Member
Thanks Meter: 1
No help huh? I did try flashing a stock rooted rom as well as the peoples rom in recovery. Still have the same result, the phone wont boot.
13th June 2014, 11:34 PM |#3  
g_money's Avatar
Senior Member
Thanks Meter: 338
I can't think of any jelp i could give, but i can give you a bump so the post stays in view. To me, it sounds like a hardware issue?

Sent from my SPH-L710 using Xparent Cyan Tapatalk 2
14th June 2014, 02:09 AM |#4  
Senior Member
Flag Minneapolis
Thanks Meter: 207
If you can't get into ODIN mode via debrick method or if the sdcard can't write the binary partition to the eMMC, I think it sounds like a case of eMMC failure from SDS. I know that stuff isn't cheap but try sending an email to Mobile Tech Videos to see if they can give you an alternative method before actually going all out and repairing the device. Josh and his crew do an outstanding job on repairs.

Other than that, I hope anyone on here can help or MobileTechVideos crew.
GL man.
The Following 3 Users Say Thank You to Spark91 For This Useful Post: [ View ] Gift Spark91 Ad-Free
16th June 2014, 07:48 AM |#5  
connexion2005's Avatar
Senior Member
Flag Texas
Thanks Meter: 721
Donate to Me
I replied to your email but this would be the result of a defective power button. We can fix that no problem...
The Following 2 Users Say Thank You to connexion2005 For This Useful Post: [ View ] Gift connexion2005 Ad-Free
23rd June 2014, 04:05 AM |#6  
OP Junior Member
Thanks Meter: 1
Originally Posted by connexion2005

I replied to your email but this would be the result of a defective power button. We can fix that no problem...

Thank You Mobile Tech Videos!!!

I found out that mobile tech videos is actually located in my home town, so I paid their operation a visit with my broken GS3. Josh had it working again less than an hour later. He even refunded me the extra shipping I paid for before realizing I could just bring it by. These guys are awesome! Now I know where to take my mobile tech any time I have a problem. PROPS!
The Following User Says Thank You to slownis For This Useful Post: [ View ] Gift slownis Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes