Remove All Ads from XDA

HTC Desire HD Superuser problem.

331 posts
Thanks Meter: 112
By Largamelion, Senior Member on 23rd June 2014, 09:44 AM
Post Reply Email Thread
I need some help with Superuser. Currently running Mustaavalkosta 's CM11 BR4 and Superuser version 3.1.3 (46).

After clean installing the ROM, Superuser works and allows me to grant root permission to apps. Temp unroot works but updating the binary immediately results in 'downloading manifest... fail!' and if I click the 'try again' button, Superuser crashes. No big deal cause everything that I need it to do, works. A couple of days later however it just stops working and no longer grants permissions... I still have root. Temp unroot stops working and crashes Superuser when I try to use it. The file /system/bin/su still exists.

Things I tried:

- clear Superuser data
- uninstall Superuser and reinstall from Play Store
- install SuperSU

None of the above works.

Please somebody help me out here, I don't want to keep restoring my Nandroid cause it still is alot of work. Thanks
23rd June 2014, 02:40 PM |#2  
Largamelion's Avatar
OP Senior Member
Thanks Meter: 112
After doing some more research I think I fixed the problem by flashing the latest instead of installing it from the Play Story where it wouldn't let me update the binaries. I can now grant root access again to apps.

Still no idea what caused the Superuser issues but I 'm glad with this 'workaround'.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes