Remove All Ads from XDA

[Q] GPS won't lock

7 posts
Thanks Meter: 0
By turbo2ltr, Junior Member on 23rd June 2014, 06:06 PM
Post Reply Email Thread
I have a stock Verizon Tab2 7.0 that I rescued from the middle of an intersection. (Replaced LCD and digitizer)

Everything works great except the GPS. I've tried GPS Test and GPS Status apps. Both show around 20 satellites, but it will not lock to any of them no mater how long I wait.

I've driven around with it on my dashboard, tried resetting the agps info, tried with and without a sim card, and most of all tried googling for an answer, but can't come up with anything that will get me a lock.

Any ideas?
24th June 2014, 06:27 AM |#2  
OP Junior Member
Thanks Meter: 0
Well I figured it out. First, I was reading the GPS test apps wrong. In both cases satellites showed up in the "radar" display and the number of satellites "in view" changed as I moved around, so I assumed that meant it was getting a signal, but apparently that's not the case.

Turns out the GPS antenna is on corner of the back cover and that corner happened to get particularly beat up when it was run over by who knows how many cars. The contact that is supposed to connect to the antenna on the cover was a little smashed and so was the antenna. To make it worse the cover didn't fit perfectly in that corner either.

So as soon as put a piece of metal on the contact, I got a lock in 5 seconds so it just wasn't making contact with the antenna in the cover. I bent the contact and it works fine now. Sorry for the post.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes