Remove All Ads from XDA

[Q] Can someone PLEASE help?!

2 posts
Thanks Meter: 0
By tryingtofind, Junior Member on 24th June 2014, 07:40 AM
Post Reply Email Thread
I think I've bricked my device.
I have a Samsung Tab 3...GT P5210. Long story short, in an abusive relationship I had files on my Tab which I needed for the court process. My ex deleted these files. I turned to my old friend Google and tried to Root my device. Stupid move but I was in a panic to recover these files. Now my Tablet only shows Samsung GALAXY Tab3 upon startup. Just the white words on a black screen. I'm assuming it's bricked.
I will be the first to admit, I shouldn't have tried. I KNOW NOTHING ABOUT THIS STUFF. I should have left it to the experts. But again, I was in a panic. Please, please, PLEASE tell me my files aren't gone and that I can undo what I've done?? I used a rooting app called Kingo.
The Tablet shows the title, as mentioned and when I connect to my computer, nothing happens. The battery doesn't show...just still the words are displayed on the screen.
As if I wasn't panicking before...
Can someone please help??? I know I sound like a moron, but I'm desperate. If I was just an idiot trying to screw with my device for no reason...but I really do need these files. I can't let him get away with what he's done to my son and I.
Thank you to anyone that can help
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes