Remove All Ads from XDA

[Q] Wifi not turning on on 4.4.3 and 4.4.4, but works on 4.4.2

167 posts
Thanks Meter: 77
By Rhian, Senior Member on 22nd June 2014, 09:29 AM
Post Reply Email Thread

- Stock (or custom) rom 4.4.2 works fine. Wifi turns on and connects.
- Stock (or custom) roms 4.4.3 and 4.4.4 hang on "Turning Wifi on..." and stay that way. (The rest seems to work normally).

I have the exact same issue with my Nexus 4, but my Nexus 7 (2012/grouper/nakasi) doesn't have any wifi issues.

Things I tried:
Complete factory resets, factory images flashed (KTU84L/P), flashed Carbon nightly (20140621).
Flashed the radio from and KOT49H factory image (there isn't one in KTU84L or KUT84P), flashed the bootloader(s) from the 4.4.2, 4.4.3 and 4.4.4.
I even tried deleting (or rather renaming) the /data/misc/wifi and /data/misc/dhcp just in case.
Router is not the problem, I already tried resetting it, despite all my other wifi enabled devices having no problems.

Nothing turns on the wifi on my Nexus 7 (flo/razor) or 4 (mako/occam) when on 4.4.3 or 4.4.4...

I am suspecting Google of screwing up, but if that was the case, why don't I see a whole bunch of posts with this problem?

I'm running out of ideas. The weirdest thing is that on 4.4.2 (stock and carbon last 4.4.2 nightly) it works like a charm! And even weirder, it happens on 2 or my 3 different Nexuses.
23rd June 2014, 01:29 AM |#2  
Saturny's Avatar
Senior Member
Flag Decatur, Ga
Thanks Meter: 72
Which roms have you tried? I'm running Pac-Man 4.4.3 (6/19 nightly) w/elementix kernel and WiFi works just fine.

Sent from my Insane S4 via XDA App.
23rd June 2014, 08:43 AM |#3  
Rhian's Avatar
OP Senior Member
Thanks Meter: 77
Originally Posted by Saturny

Which roms have you tried? I'm running Pac-Man 4.4.3 (6/19 nightly) w/elementix kernel and WiFi works just fine.

That helped, sort of... ElementalX 2.13 doesn't work for me either, but 2.12 does!

I will test some more, but I'm considering staying on this combo for now until 4.4.4 (or maybe higher) matures a bit.

I still find it highly suspicious that Stock is giving problems too. I found a few comments on 4.4.3/4 release news posts on the net with this issue too.
23rd June 2014, 11:24 AM |#4  
Senior Member
Thanks Meter: 136
I'm on 4.4.3 on Nexus 7 2013 (LTE) and mine does "Turning Wifi on..." hang every day. I reboot and the problem is sometimes fixed. If I reset my AP and then reboot the Wifi always works.

This is relatively new. I associated it with a newly installed App, Wifi Scheduler, but maybe its not the App.


Thanks for posting your question.

PS: I'm on AT&T prepaid SIM card, FYI.
PSS: I just had a problem with my PC network access, seems my DHCP router issued a duplicate IP address. Unsure if related.
24th June 2014, 02:54 PM |#5  
Rhian's Avatar
OP Senior Member
Thanks Meter: 77
Whatever the guys over at Carbon Rom did, it fixed my WiFi problems! Thread is Here.

They put some special fix in their rom. Nightly of the 24th has the fix. Those on a deb/lte will be fixed in tomorrow's nightly.
The Following User Says Thank You to Rhian For This Useful Post: [ View ] Gift Rhian Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes