Remove All Ads from XDA

Is there a fix for the MCP connection fail thing?

135 posts
Thanks Meter: 13
By Monkey Chops, Senior Member on 24th June 2014, 07:41 PM
Post Reply Email Thread

I'm having some issues where the MTP driver fails to load. Tried all the obvious stuff and did a lot of reading of forums and stuff but can't find a fix. Could anyone help me to fix it please?

Here's what hardware I have and what I've tried so far:

Tab Pro 8.4 16gb wifi UK model, rooted.

Connected via cable to Dell XPS 17, latest USB drivers installed, win 7 x64.

First of all, I enabled USB debugging and windows installed drivers for all except MTP.

Tried installing the Samsung driver package, same problem. Uninstalled at present.

Installed kies, didn't work, wouldn't even connect to the device. Uninstalled.

Followed the instructions on the wiki but the suite software installs the driver succesfully but then windows won't accept the driver. Tried the workarounds in the wiki but still no luck.

Tried rebooting the tablet and leaving the cable connected.

Tried wiping the cache.

Tried restarting both the tablet and laptop after reinstalling software and drivers, still no luck.

Found several workarounds on my travels, one was a command line for windows to add to usergroup ( it's on the laptop downstairs, will add it to the post tomorrow).

One post said to change a registry entry...really? Tried that, and another registry trick, but still no.

Using the same laptop, I had similar problems trying to flash a custom rom onto an s4, but the CM installer worked first time. I've done a fresh install of win 7 since then.

Can anyone shed any light on this for me please? Is there any kind of workaround? Running out of ideas!

25th June 2014, 12:22 PM |#2  
OP Senior Member
Thanks Meter: 13
Fixed this, well, kind of. Here's a quick rundown of what I did, for people like me who are struggling with connection problems.

I thought I had tried everything, was going to dump the whole thing and then remembered that I'd fixed some previous USB problems (sound card) by doing a clean boot.

First, remove Kies.

The only other thing that is required are the samsung mobile drivers from their website. I tried with and without and this would only work with them installed.

Restart your tablet, make sure MTP is selected.

You can find out how to do a clean boot for you version of windows here.

Leave your device connected via USB cable. Once you have clean booted into windows, windows will attempt to install the drivers from windows update, let it do this. It can take a minute or two to complete. You should then see a green tick in the notification area rather than the dreaded red cross.

If, for some reason, the driver doesn't install first time, you can unplug and then plug back in the USB cable and this should do the trick.

What I did find, is that the connection wasn't consistent, I could restart either my laptop or tablet and then it wouldn't connect, so I'd have to go through the above process again to get it to connect.

Doing this allowed me to flash the Clockworkmod recovery with odin 3.09, but for whatever reason, I was still unable to use the recommended Eimdall suite to flash cyanogenmod.

In the end, I downloaded the CM11 zip file to my tablet (via http) and then used ES file manager to move it to the SDCard root and then clockworkmod picked it up from there.

Also, once CM was installed, there were no connection problems at all, as far as I can see.

Hopefully this will help others in the same predicament.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes