Remove All Ads from XDA

Calling Dr.Ketan need to reach you

48 posts
Thanks Meter: 4
By mithudas28, Member on 26th June 2014, 07:14 AM
Post Reply Email Thread
Dear Dr.Ketan

since I have recently registered I am unable to post anything on the development thread. I am facing a serious problem. and I am asking you this because I had backed up efs.img 20 Mb and it has helped me restore earlier. but now it's failing to restore my efs. I am explaining the problem below.

I have a sm-n900 exynos and I have lost my imei and baseband during a Samsung flash. I have a TWRP backup, efs.img backup by dr.ketan's backup tool but nothing is able to restore my efs. I have scanned emmc blocks for bricked blocks and all blocks come back as non-corrupted. may be the partition is corrupted .how do I erase my efs partition to rebuild it. I have tired to flash PIT from ODIN but that too doesn't work.

1. could you tell me if it's possible to extract the efs.img to the efs files and will it help.
2. do you think there is a way I could retore from your tool using some other method.

i have tried the following things too

tried this post

but need a guide to identify the partitions and how to rebuild them. by any chance if you know if I could extract twrp backup to files to restore efs or from efs.img so I can use the nv_data.bin, since tried restoring the backups and it didn't restore I feel the partition might be corrupt and hence not being re-written. so might be I have to rebuild the partitions by formatting as explained in this thread. but I don't know exactly the steps for exynos variant. I tried using terminal on twrp but mkef2 command shows mmbcblkp03 doesn't exist which as I have read in posts is the efs partition on this phone and reboots to twrp recovery. and mmbcblkp12 show filesystem too small and reboots to twrp recovery
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes