Remove All Ads from XDA
Honor 9 Lite

Bricked my phone, need some help

72 posts
Thanks Meter: 18
Post Reply Email Thread
Got a brand new vs980 from Verizon with stock OTA 24A on it. I rooted and then used the KITKAT 24A OTA FREEDOM file from this thread to try and install TWRP 2.7. It ran, asked me if I wanted to boot into recovery. I chose yes. It appeared to have worked fine. However, now my phone just gives me the ERROR: boot certification verify screen. I've tried to get into download mode, but it never makes it past the first screen (dots). It never makes it to the screen with the progress meter and the usb icon. It seems to be properly bricked. Is this thread my only hope?
26th June 2014, 03:23 PM |#2  
D-meist's Avatar
OP Member
Rancho Cucamonga, CA
Thanks Meter: 18
C'mon guys, this is a crisis. On my way to work this morning i had to listen to the radio! Like, with commercials and stuff.
30th June 2014, 04:17 AM |#3  
Junior Member
Thanks Meter: 1
Thumbs down
Any luck? My phone is doing the exact same thing. I can't get into download mode or fast boot. The LG sign pops up, the error flashes for less than a second in the upper left hand corner then the screen goes blank and does nothing else until I hold the power button for 10 seconds or power button + volume down key, then it just repeats the LG sign and message all over again. We're screwed brotha
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes