Remove All Ads from XDA

Widgets Stopped Sticking to Homescreen

54 posts
Thanks Meter: 18
By SanguiniusWept, Member on 27th June 2014, 04:54 PM
Post Reply Email Thread
A weird thing has been happening to my S5 since I got it, both before and after rooting. For some reason, not all widgets want to stick to my homescreen in the stock Samsung launcher. When I first got the phone, they all worked, as far as I could tell (I didn't investigate fully at the time, since I had no reason to suspect that they wouldn't work). After a little while, though, I found that I couldn't make Beautiful Widgets widgets stick. I long-pressed the homescreen, chose BW, selected a widget style/size, and customized it in the BW menu, just like it's supposed to work. But no widget appeared on the homescreen. What was weirder was that in the BW app itself, it listed my widget as working, even though it obviously wasn't. Uninstalling/reinstalling the app did nothing but clear the "existing" widget I had created from the list within the app interface.

At first, I thought this problem was limited to BW, so I just got rid of it and decided to jump to another app, but then I found that HD widgets didn't work, and another similar clock/weather-style widget group wouldn't work. Thinking maybe I had created some sort of data corruption, I did a factory reset, which worked for a while, but eventually the widgets stopped working again. After rooting, and finding that the problem still existed, I factory reset again, and started putting my apps back on one at a time, testing to see if it was a conflicting app causing the problem. No luck. The widgets worked until some random time when they simply no longer would.

I finally resolved to go without this kind of widget, since it wasn't a necessity, just a convenience. The problem is that I've now noticed that other kinds of widgets aren't working, either, including some that I'd really like to have work, like the Tasker timer widget.

Has anyone else noticed this problem occurring on their Verizon S5s? I'm going to look into which widgets actually still work (because some do), and which don't, and compile a spreadsheet, see if I can come up with a reason. I doubt I'll be successful, but it might be useful for other people who actually know how to fix things.

PS. Another weird thing is that the widgets stick to Nova Launcher homescreens just fine. Now, that would be okay, except that I want to do some theming now that we can flash some ROMs, and I thought that theming only applies to the stock launcher. Plus, I'm guessing that this isn't normal behavior and I do want to find out why it's happening, not just use a workaround.
27th June 2014, 05:59 PM |#2  
SanguiniusWept's Avatar
OP Member
Flag Lincoln, Nebraska
Thanks Meter: 18
After some more digging, I've found that, with only a few exceptions, the widgets that require some sort of customization before placement on the homescreen are the ones that don't work. All widgets that are simply "click-and-drop" work fine. But, if I click a widget and it opens up a configuration page, 9 times out 10 no widget will appear on the homescreen after the configuration.

It doesn't seem to matter what size the widget is, whether the widget's app is stock or third-party, or if it is solo on the widget page or part of a group of widgets from the same app.

Plus, there are some exceptions to this, such as Google Play widgets, Mint, and Email Me Pro. Others work sometimes, depending on what configuration you apply to the widget. For example, the stock Picture Frame widget works when you shuffle the pictures, and doesn't when you choose where to draw pictures from.

Very strange. I'm thinking my only course of action might be to go nuclear and flash a completely different stock image onto my phone through Odin. I downloaded one from this post: If I'm correct, this tar image should be exactly the same as the one that was on my phone from the factory, presumably minus whatever problem mine currently has. We'll see how it goes, I guess.
27th June 2014, 07:16 PM |#3  
SanguiniusWept's Avatar
OP Member
Flag Lincoln, Nebraska
Thanks Meter: 18
Okay, so flashed the tar image through Odin, reloaded some stuff without rooting (yet), and everything seems to be going fine so far. I'm pretty sure that by this point in my previous experiment, the widgets had stopped working. I think it must have been some sort of corrupted file deep inside my system that isn't there now.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes