Remove All Ads from XDA
Honor View 10

MTP USB device drivers installation Fail

2 posts
Thanks Meter: 0
By cverrcv, Junior Member on 27th June 2014, 11:22 PM
Post Reply Email Thread

I'm using a Bell Canada Samsung Galaxy S4 model SGH-i337M.

I tried to install the following driver I download from this one of the XDA Forums: SAMSUNG_USB_Driver_for_Mobile_Phones_1590

During installation everything went fine but the part related to MTP USB device Failed.

This problem has been encountered for all the other drivers version I tried to install.

Every time I have been trying to install a driver, I always uninstalled the previous driver and rebooted before to install the new driver.

I even ran the USB driver cleaner application DriveCleanup version befor and rebooted in order to make sure that no other USB drivers would remain on my Windows 7 x64 based computer.

No matter what I tried, I've never been able to install the MTP USB device driver installation successfully.

I would appreciate it very very much if someone could help me solve this annoying problem.

Thanks in advance.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes