Remove All Ads from XDA
Honor View 10

No Data Samsung Xcover 2 GT-S7710L -- Latin Version

10 posts
Thanks Meter: 1
By alforddm, Junior Member on 23rd June 2014, 09:11 PM
Post Reply Email Thread
This all started when I ran out of data on my device and decided to root it so that I could use the SD card. I had previously rooted a droid 2 and a galaxy nexus so I wasn't a complete noob but I'm not in any way a programmer and I had never used Odin. So not wanting to mess with things without having a back up I followed some tutorials and downloaded the android sdk and used adb to back up. I thought I was doing a full system backup but whether I made a mistake or this simply doesn't back up everything I don't know. The file size should have been a clue but I missed it. I did get my apps

I then proceeded to follow the tutorials on this site for rooting the device. They are all for the GT-S7710 but I was hoping the letter (L) was a program only type thing and wouldn't make a difference. I used this guide and downloaded the DEODEXED Version. I then rebooted the phone and everything appeared to be working fine and I was rooted. I could have sworn I had data. I then realized that I didn't have CWM as a recovery so I downloaded and installed CWM recovery It was after rebooting (and maybe a reset I can't remember at this point) that I noticed I had no data.

So I flashed a few other ROMs including VANIR (and the recovery he suggests) I and CM 11 plus a stock rom (S7710LUBAMC1_S7710LUUBAMC1_CHO Samsung kies tells me CHO is the region for my device) but didn't have mobile data in any of them.

Still hoping to get mobile data working again I flashed a stock Recovery and A stock Boot.img from here...(Well I can't seem to find the thread now). It was a link to the stock boot.img and stock recovery.img (GT-S7710) from someone wanting a CWM recovery built. I then reflashed the stock ROM from above still no mobile data. My flash count in download mode is up to 26 lol and nothing I have tried restores the mobile data although as long as the phone boots, I do have wifi.

Is there ANYthing else I can try? I would really like to have my mobile data back even if it means I don't get to root.
28th June 2014, 03:02 AM |#2  
OP Junior Member
Thanks Meter: 1
No data connection
It turned out my no data was caused by not having any APN settings after flashing the custom ROM. I copied the settings from hubbies phone and now data works fine. I can't believe I spent so much time working on this and trying different things when it was something so simple.
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes