Remove All Ads from XDA

[Q] Music not detected when on SD card

9 posts
Thanks Meter: 2
By survietamine, Junior Member on 26th June 2014, 10:52 PM
Post Reply Email Thread
Hello, I've just bought an used i9505. As it was an italian version and I live in France, I flashed via ODIN the latest 4.4.2 official.
As this is nearly my 10th android smartphone and I have always used custom roms, I wanted to try the "original" Samsung ROM.
But I faced this issue : same mp3, when on sd card (in Music directory) are not recognized by the build in audio player.
So I decided to download and try some players from the playstore.
The only 2 ones that can see my mp3 are n7 (but refuse to play some formats like .ape with free version) and "audio player" (from Mobile_V5).
Same files, when are copied to internal Music directory are seen.
The SDXC card (Samsung 64 GB UHS-1) is recognized by the device, when I put files on it, I can see/add/move/delete from a file manager (mine is X-plore).
I've also tried several apps from the store that propose to rescan the SD card, and didn't help.
So, if you can tell me more about this problem please ?
27th June 2014, 12:07 PM |#2  
Senior Member
Flag Amsterdam
Thanks Meter: 645
Try formatting your sdcard. In the past this worked for me to get passed strange problems like this.
28th June 2014, 03:23 AM |#3  
OP Junior Member
Thanks Meter: 2
Originally Posted by Lennyz1988

Try formatting your sdcard. In the past this worked for me to get passed strange problems like this.

Sorry, I forgot to write it, but I did after I have moved the mp3 files. I've decided to try custom roms, so started by root my device. Currently my S4 is still running official rom but rooted.

Before flashing a new rom, I've installed Titanium Backup and hoped to save app's data into my SD card as I did with all my previous devices. From Titanium's settings it is not possible to choose some directory of sd card as backup location. It's the first time I encounter this error on one of my Android devices. From terminal app, I can see that extSdCard is mounted with 'rw' option, so not read-only, and as I wrote, I can put files on it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes