Remove All Ads from XDA
Honor View 10

[Q] [SOLVED] Apps not working with wifi but no issue through browser or 4g

4 posts
Thanks Meter: 1
By moyennes, Junior Member on 28th June 2014, 09:10 AM
Post Reply Email Thread
So I updated to NC1 and rooted and went on with my ricing as usual but I ran into this unusual problem after about a week. Keep in mind I did not change any settings anytime close to before this happened. Apps like Facebook, Twitter, eBay, Paypal, and even the Play Store stopped working over wifi but others did such as my chanu, Craigslist, email, etc. If I go to Twitter, Facebook, eBay, etc. through Firefox everything works properly but not in the apps themselves. If I disable wifi everything works fine off of 4g.

Here are some of the things I tried in order

- rebooted device
- cleared cache of applications with issues
- booted into recovery cleared my whole cache partition
- uninstalled apps but even Play Store wont work over wifi so I had to load it up in Firefox then reinstalled
- forgot wifi network and re connected
- restarted modem
- tried with the internet at my sisters house when I was over a few days ago and still did not work. She has a note 3 and everything worked properly for her

So at this point I was willing to try anything. I rebooted my device without my SD card just for the sake of desperate troubleshooting. When I booted into it all my active logins were gone. I tried logging into my twitter and it returned an error but not an error like before just saying my network connection wasn't working properly it said something along the line of "Unknown Hosts file"

Now I am fairly familiar with the GNU/Linux system (running Arch Linux for over a year) but I cannot think of a reason why my hosts file could have been modified on my device. Even if it was modified why it would bring issues like this? Shouldn't default to my Routers DNS server then?
28th June 2014, 09:14 AM |#2  
Senior Member
Thanks Meter: 212
Do you have adblock app running?
The Following User Says Thank You to jmjoyas For This Useful Post: [ View ] Gift jmjoyas Ad-Free
28th June 2014, 09:18 AM |#3  
OP Junior Member
Thanks Meter: 1
Originally Posted by jmjoyas

Do you have adblock app running?

It was running originally but I disabled it and changed my network setting back to not use as a proxy and the issue was still there. I probably should have mentioned this above. Really not looking forward to it but I feel like I am going to have to flash back and start all over with my ricing/settings.

[EDIT1]Alright I just uninstalled it completely and set my proxy setting to none and still have the issue. I am going to clear my cache partition with it uninstalled and see what happens.

[EDIT2]Well what do you know it worked after I rebooting and cleared my cache partition. I think it was more of the fact of rebooting then clearing the cache. Going to go ahead a give you a thanks for reminding me about adblock, I just kind of ruled it out as an issue when I disabled it the first time. Cheers!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes