Remove All Ads from XDA
Honor 9 Lite

[Q] Can someone help me resolve a root access issue?

7 posts
Thanks Meter: 0
By gtmgtm, Junior Member on 29th June 2014, 11:49 AM
Post Reply Email Thread
I have a Advent Tegra Note 7
Upgraded to kitkat and OTA 2.4.1
Used Tomsgt supertool 2.4.1 tool to root, installed TWRP (and made a backup image of my freshly installed system)

I've since added some games and apps and spent a fair bit of time customizing the system, but when I attempt to run Titanium Backup it tells freezes when "asking for root rights" so I ran "root checker basic" from playstore, which tells me I don't appear to have proper root access..

Here's a break down of what I've done, I've tried to keep it conscise...

I have tried installing a SuperSU, SuperUser and SU Update fixer, Also reinstalling the using both cwm and twrp... Still no proper root access.

Ideally I'd like to try some other things to get root access before reflashing and having to reinstall my apps and settings, can anyone help or suggest anything else I could do.? I can't think of anything I could of accidentally done to break root access, this is still quite a clean system just setup in the past two days.

P.S.When using the supertool impacter tool and scan for usb driver I get a "no such device" error, even though the device is listed in the previous screens.. also I suspect the correct drivers are there as ADB seems to work fine
29th June 2014, 01:58 PM |#2  
Senior Member
Thanks Meter: 533
Donate to Me
they flashing from I haven't had issues with root via either method.

If that fails you can use the n7root.img which is downloadable here: then go into fastboot mode and then type fastboot boot root_tn7.img. DO NOT USE FASTBOOT FLASH BOOT with this image as it will make it bootloop, just use fastboot boot command.
29th June 2014, 08:45 PM |#3  
OP Junior Member
Thanks Meter: 0
Thanks for the pointers hacktrix2006.. I tried also v2 no luck. Had a quick look for how to get into fastboot mode.. couldn't access it from the bootloader.. so decided to take a backup image and restore to stock kitkat 4.4.2 via tomsgt latest tool 2.4.1 including doing Wipe data. then reinstalled TWRP then applied root.... AND noticed a screen saying something like ROOT ACCESS MAY BE FAULTY.. WOULD YOU LIKE TO FIX THIS.. I also think there was a warning about "be careful this action is irreversable" - I suspect the previous time I hadn't understood this properly and selected NO !! Anyway this time I said yes and now have ROOT YAY!

Now I start a re setup of the system and installation of apps etc.. I guess it's often a bit smoother 2nd (or 3rd 4th etc) time around

OK thx again for the encouragement, plus now I have a little more experience to offer someone else who may be struggling in this area.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes