Remove All Ads from XDA

ESN wrong, yet correct? Swap troubles flashing S3 to Boost, help please.

82 posts
Thanks Meter: 31
By SweetBearCub, Member on 30th June 2014, 08:13 AM
Post Reply Email Thread
Apologies for the length of this post, just trying to put everything in order and not miss anything.

I have an old Boost Mobile 'Pay As You Go' account that is no longer offered, which has extremely cheap (35 cents/day) unlimited 3G data. The account is tied to a donor Sanyo Incognito, that is, that is the phone listed on the account.

Using some guides a couple years ago, I changed the ESN and MEID of my original Galaxy S (Epic 4G) to identify itself as the donor Incognito. This worked fine. Later, since I wanted a newer phone and would be using the phone (to talk) a lot for several months, I got a Boost Mobile S3, and it had its own account. Now, I've suspended that account, but want to move my old PAYGO account to the S3. I looked up some guides, and after finding my MSL and downgrading the modem to LG2, I put the phone into diag mode and used EFS Explorer to modify two EFS items, 0 and 1943, per this post - Due to the age of the thread (disregard the last post in it), I can't reliably ask for help.

I followed the instructions, and got an error message when trying to enable mobile data, something about needing to insert a SIM card. However, 3G data worked fine, despite there being no 3G icon in the status bar. Some further reading suggested that I downgrade and unroot back to stock. I found the oldest ROM I could, about 4 versions prior to the 4.4.2 update. I used Odin to install it, factory restored, and upgraded 1 by 1 to the latest ROM.

Now, there is more error about needing a SIM card, and I do get a 3G icon and working data - However, there are still other issues.

Whenever I reboot the phone, I get a brief "Preparing Network" line in the status bar. It goes away within seconds.

Also, when I enter ##DATA# (##3282#) and click View, then Advanced, in the list the results, the first 2 items are MEID and ESN. In the MEID entry, it has my hex and dec MEID, both correct. In the ESN entry, it has the hex and dec ESN, both wrong, still the S3's original values. When I did this on my 1st S1, it automatically derived the ESN from the MEID, no idea why the S3 isn't.

Are these errors likely to cause issues? If so, how can I fix them?
The Following User Says Thank You to SweetBearCub For This Useful Post: [ View ] Gift SweetBearCub Ad-Free
30th June 2014, 11:32 AM |#2  
roirraW "edor" ehT's Avatar
Recognized Contributor
Flag Columbus, OH
Thanks Meter: 4,751
Donate to Me
Hi! Long, maybe, but completely pertinent and easily understood, so bravo to you! ☺

I can only address the "Preparing Network" notification, although I've never used the S3 with any ROM older than MD4. But I do remember that before ND8, the phone would annoyingly present that message whenever enabling internet by any means (WIFI or mobile data).

I'm SO glad it doesn't do that any more, FYI!

[BATTERY] Plasma Battery! 🆕🆒🆓 & wickeddecimalbarwide_colors

Charging still shot

n00b-xda-disciple's Wicked X Video review

Sent from my Sprint Samsung Galaxy SIII on TouchWiz 4.4.2 with Conquest: Singularity v2.2, Ktoonsez' latest kernel and the latest Philz Touch Recovery.
Post Reply Subscribe to Thread

carriers, change, esn, flashing

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes