FORUMS
Remove All Ads from XDA

[info] Easily solve Invalid IMEI Issue with Engineering Mode trick for Micromax A116

3,841 posts
Thanks Meter: 4,932
 
By cmahendra, Recognized Contributor on 27th July 2013, 12:31 PM
Post Reply Email Thread
23rd May 2014, 06:54 PM |#31  
Member
Thanks Meter: 17
 
More
Invalid IMEI Help
I Do the Procedure Correctly
But when I enter My IMEI and Press The Button "Send AT Command" Nothing Happens
No network Coming In both the SIMS
Please Help ME
Canvas HD a116i
 
 
26th May 2014, 02:46 PM |#32  
c-non's Avatar
Senior Member
Flag TEKİRDAĞ
Thanks Meter: 128
 
More
Hello,i need latest modem.img file(in 2014),can you give me link ?
2nd June 2014, 12:15 PM |#33  
Junior Member
Thanks Meter: 0
 
More
Help!
Quote:
Originally Posted by 9803150950

Thank You so much buddy ... You save me ...

Micromax care center told me it won't be repaired ... But you did it for me ... Thanks again

Anup

Sent from my A210 using xda app-developers app

Hey buddy. I am facing the same problem. The worst thing is, sp flash tool is not working. also i am not gettting any proper diver for canvas 4
Can yu give me some link to go though?
1st July 2014, 07:59 AM |#34  
Junior Member
Thanks Meter: 1
 
More
Unhappy i have the same issue
[QUOTE=revolutionyzer;50901388]I had the same problem. But ultimately solved it.

If your baseband version is unknown, then you hav only one way to solve the issue.

>Download the a116 stock rom.

>click on scatter loading and select the 'emmc_scr' file from the stock rom.

>options >tick usb mode and da download >Force to high speed

> connect the phone without sim cards , sd card and battery.

>now click on format > then tick the first option ( whole flash )


After this, unplug the phone. Close the tool.


> Reopen the sp flash tool.

>select the same emmc file and do the same with options.

> connect the phone

> download.

This will take some time.

After this is done , follow the wngineer mode procedure , it'll work.... !


few days back in normal condition i got a message that my internal sd card is damaged & no network was detected.

i formatted my internal sd card & imei no was showing invalid.

i tried to send imei no. using engg. mode but it says ap failed to send.

since i have very little knowledge about android, please suggest me the best way to solve this issue.

my phone has jellybean 4.1.

can i upgrade it to 4.2 in this situation????????

since it has been a headache to me since few days please help me out.................

thanx in advance
The Following User Says Thank You to melonezz For This Useful Post: [ View ] Gift melonezz Ad-Free
18th July 2014, 01:33 AM |#35  
Milandas01's Avatar
Senior Member
Flag Malda
Thanks Meter: 28
 
More
Take advantages Frm Dev
12th September 2014, 11:51 AM |#36  
Senior Member
Thanks Meter: 210
 
More
from above method i solve imei problem permanetly.
but not able to solve vnram problem or wifi mac adress problem .(i find solution but not permanet every time i flash rom or custome rom problem come)
any permanet solution of nvram plz suggest

plz can u tell how to fix {WiFi NVRAM WARNING: ERR 0x10}.
18th September 2014, 09:32 AM |#37  
i_4_u89's Avatar
Senior Member
Flag mumbai
Thanks Meter: 25
 
More
Arrow micromax imei
Quote:
Originally Posted by cmahendra

Micromax Canvas HD A116 can be started in Engineering Mode for changing settings and testing hardware segments with following command on DialPad

Sections inside are...

  • Telephony
  • Connectivity
  • Hardware Testing
  • Location
  • Logs and Debugging
  • Others
*As soon as you press last asterisk (*) it will go in Engineering mode.
This should also work on A210 Canvas 4 HD
There is a great Video on Youtube by Sameer Nagdeve to resolve the Invalid IMEI issue very easily with this MTK Engineering mode. MANY THANKS TO SAMEER NAGDEVE. It was not available before when many of us lost IMEI due to mis-adventures to solve screen flicker problems etc.

WARNING: This is not for everyone. If you dont know any command, just leave it. By just playing around with options without exact known expectations, you may end up in fainted phone.

EDIT: More info in Post # 8 about another method.


Hope this helps some.

Some more references:
1) http://forum.xda-developers.com/show....php?t=2843373 This method is successfully worked for @Johnny199314 (17-08-2014) on his A117. The chipset of A116 and A117 is same and this method should work for A116 also. Always use at your own risk.

2) http://www.skyneel.com/2013/08/How-t...0858252369&m=1 WORKED PERFECT for Himanshu Balayan (reference) Always use at your own risk.

3) This also worked for many http://www.androidjugaad.com/index.p...0-steps.834%2F Always use at your own risk.




THANK YOU guys this working i tryed in my micromax A115 my imei 0000000 b4 flashing i tryd this is working 100% wooooow {sorry for my bad English}
18th September 2014, 01:28 PM |#38  
cmahendra's Avatar
OP Recognized Contributor
Flag Mumbai
Thanks Meter: 4,932
 
More
Quote:
Originally Posted by i_4_u89

THANK YOU guys this working i tryed in my micromax A115 my imei 0000000 b4 flashing i tryd this is working 100% wooooow {sorry for my bad English}

congratulations
21st September 2014, 09:36 AM |#39  
Dricera's Avatar
Member
Thanks Meter: 12
 
More
Info 2
Quote:
Originally Posted by superdude.xi

Invalid IMEI Help
I Do the Procedure Correctly
But when I enter My IMEI and Press The Button "Send AT Command" Nothing Happens
No network Coming In both the SIMS
Please Help ME
Canvas HD a116i

Did you restart your phone after sending the command? The imei will be set after a reboot.
21st September 2014, 09:57 AM |#40  
Dricera's Avatar
Member
Thanks Meter: 12
 
More
Smile Another convenient method:
So after continuously switching back and forth roms to test whether they are bugless enough for daily use, I had this annoying problem of the IMEI no. going invalid or null (null in case of CyanogenMod).
I always had to go through that lengthy engineer mode procedure again and again and it was pretty annoying..
But here's a really simple solution to this that I found:
You need to have a valid IMEI first (this is for those who flash often or are planning to flash a new rom)
1. Verify that your imei no.s are correct in your current rom.
2. Download Mobile Uncle Tools from Play Store (or apk, whatever floats your boat )
3. Look for IMEI Backup/Restore in the menu.
Click image for larger version

Name:	Screenshot_2014-09-21-14-14-31.png
Views:	153
Size:	212.1 KB
ID:	2944896
4. Back up your imei numbers. They'll be stored as imei.bak on your sdcard.
5. I'd personally recommend backing upon both internal and external, just to be totally failsafe.
6. Now everytime you flash a new rom and get an invalid imei error, just install MobileUncle tools and restore from the sdcard.
Click image for larger version

Name:	Screenshot_2014-09-21-14-14-43.png
Views:	150
Size:	125.1 KB
ID:	2944897
7. You might need to reboot for changes to apply succesfully.

Hope that helps y'all
24th September 2014, 02:12 PM |#41  
Member
Flag Goa
Thanks Meter: 2
 
More
Thumbs up Urgent help required
Quote:
Originally Posted by Megatron007

format your mobile using sp tools and flash your stock rom ..hence your baseband n imei no. will show


Note- Backup your internal memory data after format data will erase


I have a similar problem where on after rom chang ( buzz) had to instal imei code in engineering mode ( which i have done many a times)
but this time i it said : AT Command send fail

so searching desperately, But one big problem is I cant use USB since it can't recognise or charge so rooted in intalled rom via sd card,
SO HOW TO use SPFLASH using sd card?
thankin you in advance
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes