Remove All Ads from XDA

Jinx Method - possible fix for lost reliable sms, mms, group text after custom rom!

120 posts
Thanks Meter: 21
By jinx01, Senior Member on 18th May 2014, 07:52 PM
Post Reply Email Thread
I've been lurking in the shadows commiserating with those experiencing these issues with sms and mms after recent flashing. I'm in AZ, have been dealing with these problems for the past month or so.

Like others posting before, flashing to the stock rooted 4.4 Ota rom restored everything to normal, but trying to go back to gummy rom or Viper jacked everything up. I would be able to receive one or two sms, one of two mms, and then nothing else until I wiped cache and rebooted. This actually only worked intermittently, sometimes bringing on the recurring multiple previous delivered message issue. I had accepted my fate, my DNA forever doomed to a stock rom, but was experiencing the horrible sensitivity issue with the capacitive buttons (gag).

Anyway, I gave it one last ditch effort to try to fix the text problem (and ditch the stock rom and the button sensitivity crap) and seem to have stumbled upon something that actually has worked for me. I'm freaked that one small mistake could throw me back into the text problems, but for now, I'm running a fully functional Viper 4.1 without any of the aforementioned issues. If there are those out there still looking for a fix (and not a new phone, like I was considering for a while) let me know with a post in this thread and i'll do my best to explain what I did and why. I am a long time user and have no technical explanation for why it worked, but it did.

My rationale (flawed or not) was to try to get the "lock" from vzw that allows text messages to be sent from the stock rom and transfer it to a custom rom. I figured that possibly when a phone is activated or new rom flashed or when caches are wiped, possibly the custom rom information is sent at that time to vzw and they then activate the cripple on messaging. SO, I did the following to try to get around that possibility:

0. Pull sim card
1. full wipe (cache, davlik, system) and flash of the stock rom
a. reboot system
2. First boot of Stock Rom: skip all adding of accounts, wifi etc.
3. reboot to system
4. after system completely booted, add sim card
5. test sms, mms, group messaging (thereby acquiring "lock" or permission from vzw to text)
a. I sent a ton. just to confirm all was working well. my wifes phone now has a billion random texts from me. i also opened up a text plus account (app on play) to allow testing of sent and received sms.
6. reboot to system
7. test again
a. after testing confirmed, reboot to recovery and PULL sim card
8. DO NOT WIPE CACHE OR DAVLIK OR ANYTHING and install custom rom (Viper for me)
9. after flash in recovery, DO NOT WIPE
10. First boot to custom rom: skip all adding of accounts, wifi etc.
a. system will be wonky, possibly not even boot due to lack of wipe. i may have been able to get away with this because i flashed from sense rom to sense rom. I've not tested this with any cm-based roms, only viper 4.1.0
b. as before skip all adding of accounts or wifi (NO CONNECTION WITH vzw during initial boot - this could be KEY)
c. REBOOT TO SYSTEM, and add sim card
11. test sms, mms, group messaging
a. i was beyond stoked to see that messaging worked. still does work. confirmed with multiple (over the last 24 hours now) sms, mms, group messaging.
b. my keyboard was totally non-functional and it only gave me option to type with voice or send emojii (used google hangouts for all my testing)
c. despite function of messaging, the whole installation was totally unstable due to lack of wipe. soooooooo....
12. reboot to system
13. test again
14. reboot to recovery
15. DO NOT WIPE CACHE OR DAVLIK, perform a "Factory Reset" under the wipe menu
16. reboot to system - cry tears of joy if you now have a bugless, functional custom rom that can message again.

I know there are likely redundancies in my methodology, and i dont know if my theory is in fact what has made this work for me now when everything else failed before, but, fact remains that it worked (is working) for me. I am very hopeful this is at least a way around the problem for those that have been plagued with it as I have.

I'll keep everyone posted with whether or not this sticks forever (i'm only about 24 hours deep), and of any other developments as I likely get stupid/courageous enough to perform additional wipes, etc. Anyone else that has dealt with this issue, your feedback (hopefully successes) and thoughts on the issue are very much welcome. Let's kick this thing.
The Following User Says Thank You to jinx01 For This Useful Post: [ View ] Gift jinx01 Ad-Free
18th May 2014, 08:12 PM |#2  
Thanks Meter: 8
Doh! Why do I have to go to work?! Stupid railroad... I will attempt tonight when I come home!

Sent from my HTC6435LVW using XDA Premium 4 mobile app
21st May 2014, 04:48 AM |#3  
orangechoochoo's Avatar
Senior Member
Beating up dumbbells
Thanks Meter: 739
Does this work for anyone else?
21st May 2014, 05:41 AM |#4  
Thanks Meter: 8
Originally Posted by orangechoochoo

Does this work for anyone else?

Haven't been able to get it to stick but I've been starting from a daily driver stock Rom. I should probably begin with a clean install as described.

Sent from my HTC6435LVW using XDA Premium 4 mobile app
23rd May 2014, 04:24 PM |#5  
jinx01's Avatar
OP Senior Member
Thanks Meter: 21
Thought I'd leave an update - things still working well. All messages still coming through and sending well. Anyone out there been able to recreate my success with this process?
23rd May 2014, 05:22 PM |#6  
Jungsoowu's Avatar
Junior Member
Thanks Meter: 1
Well, seems very conplex. Will this work on every phone?
23rd May 2014, 11:43 PM |#7  
jinx01's Avatar
OP Senior Member
Thanks Meter: 21
Originally Posted by Jungsoowu

Well, seems very conplex. Will this work on every phone?

works on every phone I've tested it with
7th July 2014, 05:17 AM |#8  
jinx01's Avatar
OP Senior Member
Thanks Meter: 21
Quick update on my end - I finally succumbed to the need to wipe cache on viper, and sure enough my old issues with sms and texting in general returned. I restored back to a nandroid made before the wipe and everything was OK again. I was emboldened to take a few risks since the ball was already rolling - I flashed Carbon Rom with all manner of wipes and with no particular consideration paid to the issue we've been discussing. Surprisingly, everything has been working perfectly with SMS and MMS. Really made me wonder what was going on back then - was it TWRP? was it the wipe? was it something solely on VZW's end that has now been cleared? Don't think I'll ever figure it out completely. Just glad that I seem to be past the issues. Has anyone else seen improvement?
Post Reply Subscribe to Thread

broken, custom rom, fix, mms, sms

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes