Remove All Ads from XDA

root 4.4.2 ??

107 posts
Thanks Meter: 4
By zezoassiri, Senior Member on 24th June 2014, 02:08 AM
Post Reply Email Thread
hi all

i installed the 4.4.2 kitkat on my device the indian version
i tried to root it but no luck
i tried this way in this thread

first of all everything seems fine , the supersu installed and can give root permissions
but after a while it can't give permissions
just like there is no supersu
it says the app gets the permission but it can't get it

i dont know what is the problem or 4.4.2 still not get root ?
and if there is another way to root let me know

thank you
25th June 2014, 05:51 AM |#2  
OP Senior Member
Thanks Meter: 4
more than 90 views and no respones

ok it dosen't matter. i figure out what is the problem and i solve it

the problem was because the KNOX is installed in the new 4.4.2 kitkat update But it was hidden and you cannot find it in the app drawer
and if you check the app manager in the setting you will find it as KSML
KNOX prevent the root from working and the option that appear when i open the SuperSu app to disable the KNOX seems to be not effective
i tried a lot of things to remove it but i end up with fails every time

the sloution seems simple just remove knox and you will be ok and the root will works great
the problem was how to delete it with no root

i noticed in my device after i flash the root file and install an app that require root the root works on this app just for less than 10 mintues and then dosen't work at all
- so i flash the kitkat room again and turn on the device
- i download the root explorer app from the google play
- root my device
after rooting, the supersu app give force close but i went to google play and update it from there and it works fine
- lunched the root explorer and give it root permission (for me it can take the permission)
- searched about KNOX
- then deleted everything related to KNOX
- again search about KSML and delete it as well

and after that everythings goes right
a installed more than 3 apps that required root and all works flowlessly
and the root cheacker app finally says i succesfuly root my device (before was say a havent rooted my device)

damm it looks easy but it freaks me out to made the root working
KNOX really is a great saftey app but very annoying in matter of rooting

i hope anyone face my problem to try my way and it could works

thanks to me to reply me
13th July 2014, 07:00 PM |#3  
OP Senior Member
Thanks Meter: 4
Another thing I noticed
the root dosen't work if you change the language from English.
I don't know why???
20th July 2014, 07:44 PM |#4  
n-ctrl's Avatar
Thanks Meter: 15
After update to official 4.4.2, I just flashed CWM with Odin, restarted in recovery mode and installed in CWM.
Reboot tablet and start SU app; the app detects KNOX and asks to disable it. Just answer yes and you are ready in less than 5 minutes.

I must admit I first used Phil_Z recovery and then SU-app hung when disabling KNOX. After switching to CWM is worked right away.
I have N8010.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes