Remove All Ads from XDA

[Q] Root Karbonn A1+ Duple Android Phone

3 posts
Thanks Meter: 0
By sabarna, Junior Member on 5th January 2014, 01:06 PM
Post Reply Email Thread
18th April 2014, 08:29 PM |#11  
Lord AJ's Avatar
Senior Member
Thanks Meter: 89
Originally Posted by shivam kamboj

I have installed it in karbonn a1+ duple su gets installed but no root acess

Could u give details of ur problem? I don't understand what's wrong.
27th June 2014, 08:21 AM |#12  
Junior Member
Thanks Meter: 0
Vroot app to root a1+ duple
Originally Posted by sabarna

Hey guys, I am a new Android user and have bought the Karbonn A1+ Duple (not the A1+ normal, but the Duple version). The internal memory of the phone is extremely low so when I read on increasing internal space, I read that rooting might be necessary to convert SD card space to internal space. So I want to know how to root my phone. I only find links to root the Karbonn A1+, but not the Duple version. Can I use the same methods described in these links? If not please tell me how to root my phone.

I tried Framaroot/ Z4Root/ Shuame/ SuperOneClick/ UnlockRoot. But nothing seemed to work. Although I was able to install superuser, but no root. Finally I came across a youtube video to root A1+ using Vroot application. And it worked for my A1 + Duple. Hope that it works for everyone else too.
21st July 2014, 10:26 AM |#13  
Vicky Andri's Avatar
Junior Member
Thanks Meter: 1
Hay ... Friend !!
Don't worry ...
A simple mathord of Rooting for Karbonn A1+ Dupple device (100% Working )

Using - Framaroot App

Steps :
1. Download Framaroot
2. Run, choose Superuser or SuperSU
3. Select Boromir or another character
4. You will see
5. Reboot device
6. Root- installed

Link For Downloading Framaroot App -

Sent from my Karbonn A1+ Duple using XDA Premium 4 mobile app
30th July 2014, 05:04 PM |#14  
Junior Member
Thanks Meter: 0
Post In case of Framaroot's 'Exploit work but installation of ... su binary have failed'
If using Framaroot's Install SuperSU fails with 'Exploit work but installation of Superuser and su binary have failed', you can try Framaroot's Execute script option (v 1.9.1 and above) to root the device via below method;

Pre-requisites: Karbonn A1+ Duple with SD Card; Settings - Unknown sources enabled
  1. Download latest SuperSU (tested ok with v2.02) CWM / TWRP / MobileODIN installable ZIP from and extract the to a folder in /sdcard/ of device
  2. Download latest Framaroot (tested ok with 1.9.3) and copy to somewhere in /sdcard/
  3. Create a file named custom with below contents and copy to /sdcard/ of device
    cp /sdcard/UPDATE-SuperSU-v2.02/arm/su /system/xbin/su
    chown root:root /system/xbin/su
    chmod 06755 /system/xbin/su
    /system/xbin/su --install
    Do remember to replace /sdcard/UPDATE-SuperSU-v2.02/ with the folder path you got the SuperSU zip extracted to. If you create the file in Windows, do save the file with 'Unix end of lines' using a Text Editor (e.g. Notepad++) and then copy to /sdcard/
  4. If you have older version of Framaroot, uninstall first, install Framaroot latest copied to /sdcard/
  5. Launch Framaroot, choose Execute script (/sdcard/custom) option and click 'Boromir'
  6. Framaroot will display "Success ... Superuser and su binary installed. You have to reboot your device"
  7. Reboot device and install SuperSU from the /sdcard/UPDATE-SuperSU-vX.XX/common/ folder
  8. Launch SuperSU. In the SuperSU prompt that 'su binary is out of date' click Continue to update the binary
  9. SuperSU would complete rest of setup and you have root

All the praises should go to talented devs of Framaroot and SuperSU.

I found this method useful in Mac OS X (& should help Linux users) where other root methods that need Windows were not helpful. I guess above method could work for other devices where Framaroot's exploit work but su binary install fails.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes