Remove All Ads from XDA

Galaxy S4 LTE (i9505) - Issues After Upgrade to 4.4.2

26 posts
Thanks Meter: 3
By igruberger, Junior Member on 6th March 2014, 12:32 PM
Post Reply Email Thread

Just a few hours after upgrading to 4.4.2 (OTA official) I started to notice some "flaws" in the new OS. Of course there are lot´s of new good things too, but wouldn´t be better if we could eliminate some of the flaws too?

That´s why I´m creating this thread - with the purpose of exchanging experiences regarding the issues and solutions found in order to improve 4.4.2 usability.

I´m starting by sharing my experience with one of the most annoying drawbacks (at least in my opinion): the way external SD card is being used. 4.4.2 simply doesn´t allow data exchange between user installed programs (and data) and external SD card. I´m an user of FX File Manager (in my opinion one of the best file managers I ever seen).

When I opened for the first time in the new OS, the following message appeared: "Your SD Card may now be read only. This device is running Android 4.4 or later and appears to have both an internal storage area and external storage. Google imposed new restrictions in the Android 4.4 KitKat Update: applications that you install yourself ar no longer allowed to write to the "secondary external" storage (the MicroSD card). Applications installed by Google, the device manufacturer, and/or your mobile carrier ar exempt from this restriction. Only applications you choose to install are restricted. Some devices may not enforce this restriction, and other may have a means of disabling it. If you find yourself unable to write to your external SD card, please contact either your mobile carrier or device´s manufacturer support.This problem can be worked around if you have superuser access. Please refer to websites/forums related to your specific device for information."


I tried to move some files from my internal download to external SD card and no transfer was possible...

After searching for some workaround, the only way I could manage this situation was by installing ES File Explorer, which found a way to overcome this limitation for file transfer. Of course it solves the issue very partially, since no other programs (including photo / film software) will be able to overcome this problem.

I invite everyone who have/had an issue with 4.4.2 to use this as a way to exchange information, creating a single thread that will make easier to find issues and solutions (if available).
The Following User Says Thank You to igruberger For This Useful Post: [ View ] Gift igruberger Ad-Free
6th March 2014, 01:36 PM |#2  
qtwrk's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 874
Fixing in general section. It was bug in leaked version but never thought they didn't fix it in OTA version? Flash 3rd kernel would pretty much solve problem I guess. But either way needs root access which means probably avoid warranty due to KNOX

来自我的 GT-I9505 上的 Tapatalk
6th March 2014, 03:05 PM |#3  
Junior Member
Thanks Meter: 5
1. Worse battery management than JB
2. More lagging in games and UI

Generally much ado about nothing imho
The Following User Says Thank You to misiu0000 For This Useful Post: [ View ] Gift misiu0000 Ad-Free
6th March 2014, 05:46 PM |#4  
jcomana's Avatar
Senior Member
Flag Maracaibo
Thanks Meter: 67
I am not installed yet the 4.4.2 update in my GT-I9505 because my carrier sure be the last one to adjust the base to post the update. (Venezuela - DIGITEL).

Regarding some of your issues, particulary the access to the SD Card, I recently read in one post on Questions section with two alternatives to activate the access to the card.

Check it and let us now if reallly working before the rest of the members take the adventure to install the 4.4.2 Kit Kat version.

Good look
The Following User Says Thank You to jcomana For This Useful Post: [ View ] Gift jcomana Ad-Free
8th April 2014, 10:49 PM |#5  
Junior Member
Thanks Meter: 0
what's up igruberger

I use X-plore on my S4, I can transfer files but I cant read newly transferred Mp3's from my external sd since kitcat 4.4 why has this stupid restriction being put in place!!!!! royally pissed off!!!!! and are you aware of any work around yet?? its not the phones manufacturer that can fix the problem, its the android software developers as its a software issue not hardware.
9th August 2014, 10:05 AM |#6  
Junior Member
Thanks Meter: 1
Unhappy Problem whit my LTE
after the update i could not receive 3G or H or H+ or LTE only Edge someone know how to fix this i'm living in Belgium my carrier is Proximus

build I9505XXUGNF1
Baseband-version I9505XXUFNBA

Thx in advantage
Post Reply Subscribe to Thread

galaxy s4, issues after update, kitkat 4.4.2

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes