Remove All Ads from XDA
Honor 9 Lite

[Q]Possible to root without unlocking bootloader?

222 posts
Thanks Meter: 35
By thecrunked, Senior Member on 6th June 2014, 05:50 AM
Post Reply Email Thread
31st July 2014, 09:59 PM |#11  
Junior Member
Thanks Meter: 2
I tried using Towelroot on my Z2 Tablet (SGP561; Build: 17.1.D.0.417) and it said it was successful, but I couldn't get SuperSU or Superuser to work no matter what I tried (and I previously had success rooting other devices) so I am assuming at the moment that it gave me a false positive on success.

I tried a few other methods each without success. Cyanogenmod doesn't support it and neither does "Safe Root". I did appear to have some success with Motochopper n7, but when it failed to reboot the device (didn't give me an option to do it manually) and then cleaned up.

Manually rebooting the device after it finished resulted in no improvements, but trying the Motochopper exploit again indicated that it recognized a previous rooting and so it failed for that reason:

[*][*] Motochopper: Android root exploit (Windows version)[*] v1.0[*] by Dan Rosenberg (@djrbliss)[*][*] Tested on the Motorola Razr HD, Razr M, Razr Maxx HD, and Atrix HD.[*] Supports lots of other devices as well. ;)[*][*] Before continuing, ensure that USB debugging is enabled, that you[*] have the latest USB drivers installed, and that your phone[*] is connected via USB.[*][*] WARNING: This will likely void the warranty on your device. I am[*] not responsible for any damage to your phone as a result using this[*] tool.[*][*] Press enter to root your phone...
Press any key to continue . . .[*][*] Waiting for device...
* daemon not running. starting it now on port 5037 *
* daemon started successfully *[*] Device found.[*] Pushing exploit...
2109 KB/s (1283460 bytes in 0.594s)[*] Pushing root tools...
1952 KB/s (91980 bytes in 0.046s)
2296 KB/s (1867568 bytes in 0.794s)
2446 KB/s (969701 bytes in 0.387s)
        pkg: /data/local/tmp/Superuser.apk
Failure [INSTALL_FAILED_ALREADY_EXISTS][*] Rooting phone...
[+] This may take a few minutes.
[-] Failure.[*] Cleaning up...[*] Exploit complete. Press enter to reboot and exit.
Press any key to continue . . .
Of course, root checkers say the device isn't rooted, but on my towelrooted phone it says that anyway unless it is given super user privileges, so I have no way of knowing if it is rooted or if it isn't. I am inclined to believe that it isn't though because TA backup fails:

 [ ------------------------------------------------------------ ]
 [  Backup TA v9.11 for Sony Xperia                             ]
 [ ------------------------------------------------------------ ]
 [  Initialization                                              ]
 [                                                              ]
 [  Make sure that you have USB Debugging enabled, you do       ]
 [  allow your computer ADB access by accepting its RSA key     ]
 [  (only needed for Android 4.2.2 or higher) and grant this    ]
 [  ADB process root permissions through superuser.             ]
 [ ------------------------------------------------------------ ]

Waiting for USB Debugging...OK
Pushing Backup TA Tools...OK
Checking for SU binary...FAILED
Requesting root permissions...FAILED

Deleted file - C:\Users\Elliander\Desktop\Backup-TA-9.11\Backup-TA-9.11\tmpbak\r
Deleted file - C:\Users\Elliander\Desktop\Backup-TA-9.11\Backup-TA-9.11\tmpbak\s
Removing Backup TA Tools...OK
Killing ADB Daemon...OK

Press any key to continue . . .

I actually do want to Unlock the boot loader, it's just that I want to back up the DRM keys first. My tablet it already unlocked to be used with any carrier, but I think it's ludicrous that these types of restrictions are allowed on such expensive hardware. At the very least Sony should officially have a tool to backup the keys when unlocking so that it can be restored to the same device.

: When I looked in:

About Tablet > Status

On the bottom under "Rooting Status" it says "Rooted"

So I'm guessing my only problem is in getting the Super User binaries to work?

EDIT 2: BusyBox Installed (from Play Store) also says my device is rooted, so something I did in the above worked. Unfortunately, the install of Busybox also failed.
1st August 2014, 01:01 PM |#12  
Senior Member
Flag Melbourne
Thanks Meter: 170
I don't know why you've had to jump through hoops, but search for "easyroot"

I ran v5 on the older firmware and v11 on the latest firmware 17.1.2.A.0.314, works perfectly, installed supersu from play store immediately afterwards.

FWIW towelroot did not work for me either on .314 but I never tried it on the last firmware
3rd August 2014, 08:36 PM |#13  
Junior Member
Thanks Meter: 2
Originally Posted by wintermute000

I don't know why you've had to jump through hoops, but search for "easyroot"

I ran v5 on the older firmware and v11 on the latest firmware 17.1.2.A.0.314, works perfectly, installed supersu from play store immediately afterwards.

FWIW towelroot did not work for me either on .314 but I never tried it on the last firmware

It's a nice idea, but it doesn't work. "operation not permitted". Here's the output from Easy Root:

=                                            =
=             Easy Root Tool v11             =
=      Supports various Xperia devices       =
=            created by zxz0O0               =
=                                            =
=       =
=        showthread.php?p=53448680           =
=                                            =
=       Many thanks to:                      =
=       - [NUT]                              =
=       - geohot                             =
=       - MohammadAG                         =
=       - cubeundcube                        =
=       - nhnt11                             =
=       - xsacha                             =
=                                            =

tr.apk not found. Trying to download from
######################################################################## 100.0%

Extracting using 7z

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
Waiting for Device, connect USB cable now...
Make sure you have only one Android device connected
BlueStacks emulator can also cause problems
Device found

Getting device variables
Device model is SGP561
Firmware is 17.1.D.0.417

Sending files
221 KB/s (1585 bytes in 0.007s)
3452 KB/s (657704 bytes in 0.186s)
368 KB/s (1133 bytes in 0.003s)
1854 KB/s (9496 bytes in 0.005s)
2670 KB/s (13672 bytes in 0.005s)

Copying kernel module...
2805 KB/s (34473 bytes in 0.012s)
249 KB/s (767 bytes in 0.003s)
1659 KB/s (13592 bytes in 0.008s)
Kernel version is 3.4.0-perf-g31245c3
Version does not match 3.4.0-perf-ge4322cd, needs patching...
1+0 records in
0+1 records out
19 bytes transferred in 0.001 secs (19000 bytes/sec)
Kernel module patched.

modulecrcpatch (by zxz0O0)

module_layout: patched to 0xCFADE050
__aeabi_unwind_cpp_pr1: match
kallsyms_lookup_name: not found
printk: not found
mem_text_write_kernel_word: not found
__aeabi_unwind_cpp_pr0: match
successfully patched

Loading towelzxperia
2211 KB/s (13592 bytes in 0.006s)
3211 KB/s (197320 bytes in 0.060s)

Waiting for towelzxperia to exploit...

towelzxperia by zxz0O0 (EasyRootTool Version)
libexploit by geohot created
doing the magic
creating vm (loljavasucks)
mount: Operation not permitted
cleaning up
Also, as I said before, my firmware is 17.1.D.0.417. Yours can't be the latest firmware if my firmware is a higher number. I'm still stuck in this limbo where some apps think it's rooted and other apps don't.

EDIT: Despite the error it gave me, I tried installing SuperSU by chainfire again and I seemed to get farther at least, but it failed. Rebooting to try again.

EDIT 2: It also gave me this error on my computer when I rebooted the device:

Checking if device is rooted...
error: device not found
Error: device not rooted
Press any key to continue . . .
But when I went into SuperSU it didn't give me any errors. I went into Root Explorer and it actually asked me if I wanted to grant super user privileges, but I don't think it's fully rooted though. The root folder is empty, and although I can see the files of other directories, it fails to touch a few things. I kind of expected that would happen to, but I also can't edit Platform.XML to restore write permissions. I have done this before on other devices so I know I was doing it correctly, but it just failed to edit. I even tried an app to do so, but it also failed. It's rooted enough to see the files and open them. I can even copy files otherwise hidden and it appears to be able to mount as read/write. It's just that it always fails to do anything with it.

I then went and installed "Mount /system (rw / ro)" and although it appeared to work successfully after granting it super user privileges, it still didn't allow me to edit the files in root explorer, so I installed FX and and it's root add on module. I tried to edit the files, but it wasn't mounted as "Read/Write" as far as it's concerned and when I tried doing so within it's menu it just said "Error" The operation could not be completed"

So... am I rooted or not? Easy Root definitely helped me get farther, but not far enough to actually do what I needed the root to do.

EDIT 3: After a few minutes, for some unknown reason, Root Explorer allowed me to edit Platform.XML to add <group gid=”media_rw” /> under WRITE_EXTERNAL_STORAGE (still won't work in FX though) and of course I still can't edit, but as a test I successfully moved some files from the internal memory to the 128 GB micoSD so I'm at least rooted enough to restore access to the SD card so I will give it some time to see how much I can do with it.

P.S. - There is a forum bug. When I edit posts on a tablet there are no problems, but when I do so on a computer it tells me I have to wait 5 minutes before writing a new post to prevent spam - even though it's not a new post, it's an edit of an old post. Just like there is a weird thing where it will let me post links in a tablet, but not in a PC. Unfortunately, there doesn't appear to be any bug report form or moderator contact links so just putting it here.
The Following User Says Thank You to Elliander For This Useful Post: [ View ] Gift Elliander Ad-Free
10th August 2014, 06:06 AM |#14  
Senior Member
Flag Melbourne
Thanks Meter: 170
well sorry no idea what state you're in. I notice you are SGP561 (whatever the heck that is!!! ), I am SGP511.
Can only say that for my device, easyroot worked 100%.

EDIT: I think you are Verizon user? well in that case good luck and get used to it lol. Verizon always have different firmware / build for their devices so you're always in the XDA development minority. Sometimes exploits and/or unlock bootloader is never available.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes