Remove All Ads from XDA

Newbie guide for rooting SGP312 Sony Xperia Tablet Z

3 posts
Thanks Meter: 5
By Magnus_E, Junior Member on 9th June 2014, 02:52 AM
Post Reply Email Thread
Hi all!

I am writing some instructions for newbies like me that wish to root their Xperia Tablet Z. I spent a lot of hours trying to understand how things work and I try to fill this gap with this post. If anybody knows, I would like to have an answer on the DRM, and model type questions that I have colored red in the text.

I was a "proud" owner of Sony Xperia Tablet Z WIFI 32GB (SGP312) that I bought from northern Europe last September. It was my first Android device and I consider myself super newbie on this "sport". Since my last official Sony system upgrade ~1-2 months ago I had sound problems with skype. I could not make a call without a handset and also my sony speakers refused to reproduce any youtube video. Nonetheless, the alarm was working fine! I was disappointed and after a factory reset the sound problems persisted. Thus, I decided to delve into the rooting world.

So long story short, we can install whichever stock/original firmware we want if it is designed for our devices consulting the precious links in forums. Then we can either stay with this or install custom "ROMs" having our tablet "rooted".

My first goal is to fix the sound problem so I tried following the stock firmware route.

I flashed the firmware(s) with the quite intuitive Flashtool. Beware that I had already installed the required Google's Android SDK/ADT kit in my windows machine, although I performed every task in my linux machine in order to have working fastboot and adb commands with the minimal fuss installation-wise. To flash the stock firmwares, or the so called FTF files, I was entering the flash mode holding/pressing down the Volume Down key while connecting the device with the USB to my PC. I note that holding down the Volume Up key, instead, connects the tablet in the fast boot mode

After/Before every firmware flashing I was trying not to forget to:
  1. Enable the USB Debugging mode
  2. Trust installation from unknown sources (this probably is redundant) and
  3. Use massive storage instead of MTP in my USB connection options.
Then, I tried to unlock my bootloader (for experimenting purposes) following the official SONY instructions. I successfully did (fastboot was saying OK!), without keeping any DRM keys, since I guess I do not need them, right? However with some FTF stock firmwares my screen was freezing while booting and showing the "flying colors" and then it was eternally rebooting again and freezing again and so on. I tried this and verified it with a couple of FTF stock firmwares. The one was for sure the SGP312 Global Xperia Tablet Z WiFi 32 GB - 10.4.1.B.0.109, I do not remember the others. This 10.4.1.B.0.109 was working fine but not with the bootloader unlocked. I found out that I could break the boot/freeze loop by entering flash mode (Volume Down while connecting the USB) just after it was turned off after the "flying color" freeze.

So I tried with this stock firmware: SGP312 10.4.B.0.577 (UK version 32GB WIFI Unbranded) and after using my tablet for ~30mins I can say that I did not encounter any problems.

But I wanted to view the rooting world, so to do this I found out that installing a Recovery Software would help.
So I installed XZDualRecovery. I followed the instructions and downloaded and also the * from the same site.

Before starting to implement the instructions, the same XZDualRecovery post was mentioning I should install a 10.3.1.C.0.136 firmware and so I did, getting the SGP312 10.3.1.C.0.136 VMo EU4 firmware. This 10.3.1.C.0.136 was also working quite well, and after unlocking the bootloader (I do not know if I have to do unlock the bootloader everytime I flash a stock FTF) it was botting properly and my speakers were working fine.
I runned the for linux (install.bat for windows). I noticed that the third option was "3/ Attempt installation on unrooted device" which I tried and was successful, since then, the "Root Checker" app was saying that my tablet was rooted. That was really cool!

I wanted to enter the recovery mode so I turned on my tablet and when the "SONY" letters appeared (or a bit earlier) I started pressing multiple times the Volume Up key and a nice purple screen (like this) with the recovery appeared. There, I chose Wipe Data/Factory Reset (it was quite fast) and then Install multiple Zip files from the SD card.

The Zips I had in my card were the Cyanogen Mod, the Google Apps and the XZDualRecovery:
  1. I downloaded Cyanogen Mod, pollux_windy for our devices, from here. I chose the latest stable version, 2014-02-01 01:07:05, but I hope another one will see the light soon.
  2. I also installed the latest google apps that for today are these and the latest versions can be found here.
  3. The metnioned above. I am not sure if this is really needed but I think I read somewhere that I should included or else I would not be able to Reboot to Recovery after flashing.
The problem with the pollux_windy zip was that I panicked since the recovery zip installation stopped with the error: assert failed [...] status 7 and I was pretty sure I had an SGP312 device!!! So I deleted the first line in the cyanogen zip file:
like it appears here or here. This forum post says I should not extract the zip, but I did and it worked.

After all the above steps I booted my tablet and everything seems almost ok so far. I say almost because:
  1. I notice that my device, according to the settings is now the "SGP311" and not the SGP312 (how could I change that?), but in my free space I still see 25+GB (although I am still using only ~3GB).
  2. Also, some times while I am scrolling e.g. in Play Store I see infinitesimal freezes in the movement of the webpage (AnTuTu benchmark returns a rating of ~19800-20118).
  3. Moreover, I have installed ~30 apps, but the installing procedure seems somehow slow, and the last ~10 apps I tried to install have not been installed "due to an error 495". The above was "fixed" after a reboot, but I must say I never encountered this problem with my stock firmware.
The Following 3 Users Say Thank You to Magnus_E For This Useful Post: [ View ] Gift Magnus_E Ad-Free
9th June 2014, 03:02 AM |#2  
Felimenta97's Avatar
Senior Member
Flag Ribeirão Preto
Thanks Meter: 2,335
To the first question in red: DRM keys are needed for Playstation Mobile, Video and Music Unlimited, I think something regarding Screen Mirroring and, until Android 4.3, no Bravia Engine 2. With 4.4, it works again.

About the 311 and 312 thing, it is because you flashed a firmware that wasn't specifically for your device. You can go into build.prop file, and change every SGP311 you find to SGP312.

Nevertheless, awesome guide

Sent from my LT26i using Tapatalk
The Following User Says Thank You to Felimenta97 For This Useful Post: [ View ] Gift Felimenta97 Ad-Free
10th June 2014, 12:10 PM |#3  
scoobydu's Avatar
Senior Member
Thanks Meter: 42
Thanks for the time to share
The Following User Says Thank You to scoobydu For This Useful Post: [ View ] Gift scoobydu Ad-Free
28th August 2014, 01:50 AM |#4  
Junior Member
Thanks Meter: 0
Hi all,

I have the SGP312 but it's not the "global" version (I noticed one of the stock firmware used was the UK one). I have the US/Canadian/North American version.

Would I brick my device if I flashed with the UK firmware? I haven't for the life of me found any guides/threads for my device.

I know it's the "pollux windy" (wifi 32gb) but I'm...afraid.

29th August 2014, 08:17 AM |#5  
Rootk1t's Avatar
Senior Member
Thanks Meter: 473
Originally Posted by UberBaumer

Would I brick my device if I flashed with the UK firmware? I haven't for the life of me found any guides/threads for my device.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes