Remove All Ads from XDA

Re-Root After OTA NAE to NC5 SM-P900 wifi only

739 posts
Thanks Meter: 337
Post Reply Email Thread
After a little pain and scouring the threads in the forum I found a way to accept the OTA and then re-root.

This is not my process it is one that I have seen in pieces and after trial error and several soft bricks I have root on NC5 and am Back cruzing away.

(--Disclaimer, this is what I did to My device and How I was Able to resolve My situation. YOUR results may be different and I DO NOT assume
any responsibility for what you do with your device.
If you are not sure if you are in the same boat or you do not understand basics of rooting, flashing and using ODIN please do you research and educate yourself)

This was my situation and how I was able to get back to root.
  1. I was on the Original Stock Rom Rooted with CF-AutoRoot... (NAE) Root NAE Life is great! (Find it in Original Android Dev)
  2. I accepted the OTA via Kies and after reboot was unrooted NC5 running fine.
  3. I tried to flash CF-Auto root several times and It always crashed and left me in a soft brick... in Odin it would get to cache and hang....
  4. I then flashed the NB3 recovery via ODIN. (I used 3.09) (reboot, Yeah, we up again...)
  5. I re-flashed CF-Autoroot and Profit! $$$
  6. went to playstore and installed superSU
  7. I then re-flash TWRP and made a back-up.

The Lesson learned here is flash the NB3 Recovery before you go Flash CF-AutoRoot.
I have attached it.

Attached Files
File Type: tar P900XXUANB3-RecoveryImg.tar - [Click for QR Code] (7.18 MB, 2123 views)
The Following 2 Users Say Thank You to Bizack For This Useful Post: [ View ] Gift Bizack Ad-Free
4th June 2014, 05:45 PM |#2  
Senior Member
Flag San Rafael, CA
Thanks Meter: 109
BIG note: Don't use a USB 3.0 port on your PC. At least for me, this was the killer for re-applying the CF Auto Root after following the above instructions. Flashing the NB3 recovery worked in Odin 3.07 and 3.09 just fine. Every time I tried to re-apply CF Auto Root, it hung on cache.img like so many others.

Like I'm supposed to do, I scoured the posts and general internet so I wouldn't ask a question that's been answered many times. What caught my eye was the repeated note to open Odin and load the file to be flashed in Download mode FIRST, then connect the USB cable. One post said to do this and wait for the Download mode drivers to load. This got me thinking that the device needed different drivers for different connection modes. If USB Debugging, MTP, PTP... were different, why wouldn't USB 2 or USB 3 also be different???? I was always in USB 3 out of habit and decided to try a USB 2 port on my PC (bingo).

1. Updated to NC5 using Kies using USB 3. Worked without issue. OTA wouldn't work b/c I was rooted already.
2. Flashed the NB3 recovery (PDA slot) as noted above in USB 3 using Odin 3.07. Worked without issue.
3. DON'T DO THIS - Flashed CF Auto Root recovery using USB 3 (PDA slot). This is where my problems started and the device was in what I think is called a soft brick.

Intermission to scour the internet and try different solutions

4. Disconnected USB cable.
5. Get into Odin 3.07, load NB3 recovery file (PDA slot)
6. Connect USB cable to USB 2.0 port (directly to mobo port, not a USB hub just in case)
7. Flash NB3 recovery. No problems
8. Disconnect USB cable from Note (still in 2.0 port on PC)
9. Reboot into Android NC5. No problems (Exchange account was gone - no big deal)
10. Connect USB cable and let the PC recognize the device. I switched between MTP and PTP to make sure both drivers were registered and it did register twice proving that these are different connection types (kind of a 'duh yeah' thing)
11. Disconnect USB cable from Note, shut down and boot into Download mode.
12. Get into Odin 3.07, load CF Auto Root recovery into PDA slot.
13. Connect USB cable to Note.
14. Start (flash). BINGO!!!!
15. Disconnect USB cable, reboot
16. Boot into Android NC5.
17. Download SuperSU and open it. Rooted again!

Are all these steps needed, maybe not. But for me, the key was to not use USB 3.0 connection on the motherboard. The cable was USB 3.

For all the times someone else posted a really thorough post that saved me time, thank you!!! This one's for all you awesome folks out there who help out.
The Following 2 Users Say Thank You to jimbob_sf For This Useful Post: [ View ] Gift jimbob_sf Ad-Free
20th August 2014, 02:59 AM |#3  
Senior Member
Flag Peoria IL
Thanks Meter: 49
Donate to Me
Works perfectly
Thanks for posting this. It works perfectly
29th August 2014, 04:25 PM |#4  
lpt2569's Avatar
Senior Member
Thanks Meter: 35
Originally Posted by James L

Thanks for posting this. It works perfectly

Post Reply Subscribe to Thread

nae, nc5, sm-p900

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes