FORUMS
Remove All Ads from XDA

[APP/FRAMEWORK] NOGAPPS Project (NetworkLocation, MapsAPI, Blank Store)

496 posts
Thanks Meter: 2,269
 
By MaR-V-iN, Senior Member on 17th June 2012, 05:43 PM
Post Reply Email Thread
31st August 2014, 11:00 PM |#801  
Senior Member
Thanks Meter: 76
 
More
Quote:
Originally Posted by sancho_panzer

Did you bother to read at least one of the previous posts?!

I have, actually, and if you would do the same you'll also notice I even posted a few findings.

As different users seem to have different issues I found it reasonable to post mine.

As we all highly appreciate the work Marvin is doing, try to keep the hostility somewhere else.
31st August 2014, 11:07 PM |#802  
Account currently disabled
Thanks Meter: 829
 
More
Quote:
Originally Posted by wkwkwk

I have, actually, and if you would do the same you'll also notice I even posted a few findings.

As different users seem to have different issues I found it reasonable to post mine.

As we all highly appreciate the work Marvin is doing, try to keep the hostility somewhere else.

Hostility? LOL, telling you to read previous posts is being hostile? LOL, you're a character.
1st September 2014, 11:45 AM |#803  
Senior Member
Thanks Meter: 87
 
More
Question
I'm having some issues with NetworkLocation not being recognized. Seems like it's not working at all: Some apps simply say I've got to enable GPS (maybe most of them are GPS only), others give a toast saying "provider unsupported".

Walking through this thread I've just found SatStat being recommended for test, so I will do that as soon as I'm back home. Apart from seeing whether that works, what could be done? I've especially watched out for an app supporting "coarse location" (thanks to my special AppSearch), it was easy to find one) – but that was the one claiming "provider unsupported".

As for installation: I had some trouble with the MapsProvider (I was not able to flash it), but found a work-around (see my (installation instructions). Verified: Works great! Having switched to F-Droid + Aptoide on that device, I did not yet check BlankStore, though.

Great job! Wonderful project! If I only could get the NetworkLocation working... F-Droid has some GSMLocationBackend), but unfortunately that's 4.2+ only (the project site seems to have a 4.1 version, but for my old device I've got 4.0 only currently – which already is a huge improvement to the latest official version, 2.2)
1st September 2014, 12:58 PM |#804  
Account currently disabled
Thanks Meter: 829
 
More
Quote:
Originally Posted by Izzysoft

As for installation: I had some trouble with the MapsProvider (I was not able to flash it)...

... but for my old device I've got 4.0 only currently – which already is a huge improvement to the latest official version, 2.2)

Seems to me these two phrases are important, you're using an old ROM and your recovery is giving you problems. Are you sure you can't update them to more recent versions?
1st September 2014, 05:11 PM |#805  
Senior Member
Thanks Meter: 87
 
More
Quote:
Originally Posted by sancho_panzer

Seems to me these two phrases are important, you're using an old ROM and your recovery is giving you problems. Are you sure you can't update them to more recent versions?

Sorry, no. The device in question is not even maintained any longer by CM (see its download-page on CM): it's a HTC Wildfire (aka Buzz) from 2010, I can count myself lucky I've found at least a ROM with 4.0.4 for it (CM 9.1). Everything else flashed fine via the recovery, only MapsApi gave me a
Code:
E:Error in /sdcard/Update/mapsapi.flashable.zip (Status 0) Installation aborted.
whenever I tried.

But as described, my manual install of MapsApi worked fine (I get the Maps displayed in apps like *RF Signal* – everything else is also working fine), it's the NetworkLocation giving me trouble (which was not flashed, but copied as by the instructions). And according to the very same instructions here, it should work with 4.0 and up.

Btw: Meanwhile installed SatStat, which is showing the cells fine (as RF Signal does as well) – but not giving me any position with GPS off. Is there any way to at least tell whether the database itself was being recognized? Just none of the cells in my area being in the database would explain something, too (though I doubt that that's the case: Austria/Germany/Switzerland are pretty well covered by OpenCellID, making up for almost a quarter of its database).
2nd September 2014, 06:23 AM |#806  
Senior Member
Thanks Meter: 76
 
More
Quote:
Originally Posted by an0n981

The way I do it is that I have a Nandroid with GAPPS where all my paid apps are installed. From there I copy the apk and the install/update on then NOGAPPS rom

---------- Post added at 09:53 PM ---------- Previous post was at 09:50 PM ----------



I have the exact same error

The latest BlankStore.apk allows updating (and installing) previously paid apps.
This pretty much makes the GSF and PlayStore obsolete (unless you need to buy something new in which case there doesn't seem to be another way).

Nice one.
2nd September 2014, 10:33 AM |#807  
Vagelis1608's Avatar
Senior Member
Flag Athens
Thanks Meter: 843
 
More
Quote:
Originally Posted by wkwkwk

The latest BlankStore.apk allows updating (and installing) previously paid apps.
This pretty much makes the GSF and PlayStore obsolete (unless you need to buy something new in which case there doesn't seem to be another way).

Nice one.

You can buy things from play.google.com and then install them with BlankStore

Sent from my D620R [Stock 4.4.2]
The Following 2 Users Say Thank You to Vagelis1608 For This Useful Post: [ View ] Gift Vagelis1608 Ad-Free
6th September 2014, 02:11 PM |#808  
MaR-V-iN's Avatar
OP Senior Member
Thanks Meter: 2,269
 
Donate to Me
More
Downloading new apps should be fixed with version 0.7.2 (in first post)
The Following 5 Users Say Thank You to MaR-V-iN For This Useful Post: [ View ] Gift MaR-V-iN Ad-Free
6th September 2014, 04:56 PM |#809  
Account currently disabled
Thanks Meter: 829
 
More
Quote:
Originally Posted by MaR-V-iN

Downloading new apps should be fixed with version 0.7.2 (in first post)

May I ask what was the problem? Recently all my browser FC on some occasions when trying to open Play Store.
6th September 2014, 05:15 PM |#810  
Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by MaR-V-iN

Downloading new apps should be fixed with version 0.7.2 (in first post)

still getting a parsing error while installing swype, furthermore an update for whatsapp failed to install and now I can't reinstall it anymore. if a logcat could help you, I can send it to you.
6th September 2014, 05:41 PM |#811  
Ultramanoid's Avatar
Senior Member
日本
Thanks Meter: 4,274
 
More
Quote:
Originally Posted by sancho_panzer

May I ask what was the problem? Recently all my browser FC on some occasions when trying to open Play Store.

Mine do too often, and have for a long time, not just recently. To be honest the Play Store site is one of the worst sites I've ever known. It causes problems or lag on every browser I have on every OS.
The Following User Says Thank You to Ultramanoid For This Useful Post: [ View ] Gift Ultramanoid Ad-Free
Post Reply Subscribe to Thread

Tags
you are limited to 8 thanks per day

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes