Remove All Ads from XDA

 View Poll Results: How U like my 1st post?

175 Vote(s)
Not bad
48 Vote(s)
65 Vote(s)
39 Vote(s)

[FIX][SOLVED]Status 7 Error with CWM or TWRP Recovery on Rooted Android!

n/a posts
Thanks Meter: 0
By AndroTix, Guest on 11th November 2013, 08:43 PM
Post Reply Email Thread
3rd July 2014, 06:38 PM |#21  
Senior Member
Flag Kandy
Thanks Meter: 36
not working
did as im getting another error..status 4
3rd August 2014, 11:52 AM |#22  
AA9's Avatar
Junior Member
Flag home
Thanks Meter: 10
Super tutorial bro
6th August 2014, 08:11 PM |#23  
brdeveloper's Avatar
Thanks Meter: 3
Originally Posted by AA9

Super tutorial bro

The assert trick didn't worked with my Note N7000. I recently repartitioned my internal storage flashing a custom PIT file so I got 6GB of "app storage". Since then, I'm unable to flash aby kernel from recovery mode. Stuff flashed through Odin seems to work. I could also flash SuperSU 0.95 (root only, no kernel) in stock recovery mode.
10th September 2014, 07:41 PM |#24  
ice.modding's Avatar
Senior Member
Flag Tucumán
Thanks Meter: 291
Donate to Me
and Status 0 how to fix it? in this case?

i tried with:

* format my internal sd
* full wipe
* full format
* update my custom recovery

PS: my phone is a G900H. (S5)
8th October 2014, 08:15 PM |#25  
Junior Member
Thanks Meter: 0
I am unable to flash even after editing that updater-script. I have tried installing using latest CM11 Nightly ROM on my P3100. The installation gets aborted without any error message as such. Please help. My Tab is dead or is there any other way to flash it?
13th October 2014, 12:40 PM |#26  
Senior Member
Thanks Meter: 48
Hi!, I started getting this message after I format system on TWRP. Now I guess I erased some file where "maguro" was stored and where the rom decides wether the it is valid or not for my phone. I did what's said in the post but now after starting flashing it only stops whitout notifications. Is there anyway to restore my system folder or the file that identifies my phone as a "maguro" model.

thanks in advance.
26th October 2014, 01:20 PM |#28  
Junior Member
Thanks Meter: 0
Wink Editing your file extension (fix)
Originally Posted by pointystar

When I tried to rename it, it stayed as a text file. It didn't revert back to the original file.

Go to the parent folder of the folder containing the file you want to rename.
In the Options on top, you should see a Tab "Organize" (Windows 7) or "View" (Windows 8). Under "Organise" in Win7 you should find another "View" tab.
Under the "View" tab, you'll find an option to enable the display of file extensions. Toggle that, and you'll be able to see and edit the extensions of all Files in that Folder and its Subfolders.

Hope that worked
5th November 2014, 03:06 PM |#29  
Junior Member
Thanks Meter: 0
my error Status 7 is about gapps.. CWM (version says to me that i have insufficient storage (i'm using micro version).. how i solve the problem? I'm in recovery now

Edit. Solved
5th November 2014, 06:50 PM |#30  
Thanks Meter: 6
Originally Posted by AndroTix

When installing certain custom ROMs on rooted Android smartphones or tablets, you will encounter “Status 7″ error issues once in awhile with ClockworkMod (CWM) Recovery.

Status 7 error is caused while the ROM’s updater script file checks to see if the phone model of your phone is compatible with the ROM you are installing, called “asserts”.

“Asserts” is a safety mechanism so you don’t accidentally install another phone model ROM on your phone. E.g. You tried to install Galaxy S2 ROM on a Galaxy S3 and ending up hard-bricking your phone but you got Status 7 error which saved you.

Now, this safety mechanism is great but there are times where even if you have the correct ROM for your phone, you will get Status 7 error.

This is due to an error by the developer of the ROM in the updater script, causing havoc, making people install another custom recovery like TWRP recovery for no reason.

You can fix the issue by installing TWRP recovery but if you need to restore your CWM backups later down the line, you will have to re-install CWM recovery, causing a big hassle.

Also, if you update to the latest CWM Recovery using ROM Manager, usually this problem is fixed.

But what if you did update to the latest CWM Recovery and still happens? And yes, it does happen even when you update your CWM recovery.

If you simply don’t want to change your recovery (because if it ain’t broke, don’t fix it) or you still get Status 7 error after changing recovery, you can simply edit the updater script yourself to get rid of the asserts.

All you need is a computer and a zipping program! (You might be able to even do it on your Android device with AndroZip and text editor but I haven’t tried yet.)

Before we begin, e.g. Make sure if you are installing a ROM on AT&T Galaxy S3, the ROM zip file you downloaded is for AT&T Galaxy S3 not for Verizon Galaxy S3.

Step 1. Copy the ROM zip file to your computer and extract it using your favorite unzipping software.

Step 2. Once unzipped, browse to the META-INF/com/google/android directory. You will find two files called “update-binary” and “updater-script”.

Step 3. Rename “updater-script” to “updater-script.txt” and open with your favorite text file editor.

Step 4. Get rid of the line starting with “assert” to next semi-colon. Usually this is the first line or one of the first lines at the top of the text file. Just delete them.

Step 5. Save file.

Step 6. Rename “updater-script.txt” back to “updater-script”.

Step 7. Rezip all the files you’ve unzipped.

Step 8. Copy the new, edited zip file to your phone.

Step 9. Try re-installing ROM, now it should install fine without Status 7 error.

When i try to do this on my OnePlus One with Aosp, i cannot find "assert" in update-script. Any solutions?
16th December 2014, 12:23 PM |#31  
Senior Member
Thanks Meter: 19
Fix status 7 error
Hello I want to install custom kernal but I cant because I am getting status 7 error help me
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes