Remove All Ads from XDA
Honor View 10

[Q] /datadata partition problem on SlimKat

80 posts
Thanks Meter: 29
By Equinos, Member on 21st May 2014, 03:20 PM
Post Reply Email Thread
I have been having problem with the SlimKat with the /datadata partition being full. i dont have many applications (i think) and i just reflashed the latest stable build a week back with full factory reset and system format. And now i have the /datadata partition full and problems when some applications fill up the cache even a little.

i tried search for solutions on google and on here, but they seem to be outdated for (mostly for CM7/CM9) and not for KK.
I only have about 50 apps installed mostly small applications like greenify, multiling keyboard es file explorer and airdroid. And i move applications to SD card when i can.

The largest application are:
Taomix 39 Mb
OfficeSuite 37 Mb
Line 27 Mb
Perfectly Clear 24 Mb
Google Music 23 Mb

And i constantly use Clean Master to clean caches and junk files.

i'm not really proficient in linux commands so correct me if i'm wrong.

The df command on terminal shows only a few kb of space remaining.

But while doing
du -m /datadata | sort -nr | head -n 20

it shows that it only has 141 Mb, so i'm guessing it only examines folders

And directory analyze on ES Explorer shows it has 265 Mb

So i'm not sure what to make of this. I'm assuming that the du -m command and the ES file explorer are showing different results because they are analyzing different things.

My question is, Is there a way to find what's the cause of this and is there a way to clean up files without messing everything.
Or is there a way to increase the size of /datadata partition and/or relink it to somewhere else.

I've found that there are scripts to do this but they seem to be outdated.

Any help would be appreciated.
24th May 2014, 08:02 AM |#2  
OP Member
Thanks Meter: 29
Is it only me that's got this problem??

24th June 2014, 05:53 AM |#3  
D0MINO's Avatar
Senior Member
Thanks Meter: 34
I have Mackay ROM 4.9.0 installed and a couple of times per day I get FC and an unusable phone due to the same datadata problem. Restart does not work and the only thing I can do is uninstall an application to make more space in the datadata folder (which is 422mb).

I kid you not when I say that I have uninstalled PLENTY of applications and at times have had upwards of 30mb free, but then a few hrs later the blasted folder is full again and I have not done anything! I have tried to see what apps r taking the p*ss but accessing the system is super slow and unusable on the phone and the time I did try, it wouldn't let me as there was like 84kb free in the datadata. When this happens, I am not able to send SMS, answer calls or do anything.

I have just seen that Mackay has a 4.9.3 out only 2 days ago so I am going to try that and see if it makes a difference. AFAIK, this problem only started recently (probably due to the not officially released 4.9.0) so fingers crossed it will sort it out. Otherwise, I will just have to do a hard reset and start from scratch....This little (NOT!) problem has seriously made me decide to buy another phone but I am still undecided which one! All the damn new ones are like 5.5" and the smaller HTC M8 is metal so looks cool but if u drop it it will DENT!...nobody mentions that just moans incessantly about the un-premium feel and look of the plastic ones - at least they are hardy and it's cheaper to replace the casing! Stupid people!
24th June 2014, 01:59 PM |#4  
pryerlee's Avatar
Senior Member
Flag Bristol
Thanks Meter: 136
there's a code that resets the data partition to factory state, the code is *#*#7780#*#* but use it only if you can't find any other solution. Use this at your own risk and mske a nandroid backup first before you try it.
25th September 2014, 04:29 PM |#5  
OP Member
Thanks Meter: 29
Originally Posted by pryerlee

there's a code that resets the data partition to factory state, the code is *#*#7780#*#* but use it only if you can't find any other solution. Use this at your own risk and mske a nandroid backup first before you try it.

if I wanted to reset the partition I could do it many ways. The problem here is the datadata partition is filling up with something that cannot be deleted even when formatted through CWM. It seems like a problem with linux partitions where deleted files arent released by processes. But I cant seen to find how to delete them you free up space.

I found the following command online and using it on terminal gives me some null and roots listings.

lsof L1 | grep deleted

This problem is fixed by flashing stock gingerbread but the problem seems to come back again. So may be its a internal memory card issue or not. i'm not sure. Other partitions are working fine without problems.

Has anyone else had this
Post Reply Subscribe to Thread

datadata, galaxy s, i9000, kitkat, slimkat

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes