Remove All Ads from XDA

Xperia Z1 not powering on

5 posts
Thanks Meter: 0
By trpincek, Junior Member on 20th January 2014, 11:12 PM
Post Reply Email Thread
3rd April 2014, 09:25 AM |#11  
funky0308's Avatar
Recognized Themer
Flag Osijek
Thanks Meter: 5,727
Donate to Me
Originally Posted by legalmantra

Hello I'm new to xperia Z1.

I also rooted and installed ihacker rom v3.

My battery was fully charged. But after installation my phone is not starting.

In flash mode when I try to flash the stock it disconnects and reconnects. I'm not even able to install stock rom now.

---------- Post added at 12:52 PM ---------- Previous post was at 12:48 PM ----------

Ok while I was typing phone flashed the stock rom. I think this problem is with ihacker rom?

No it's not.
Ihackers is working without any problems...

I said that many times but I'll repeat...

When you are flashing ROM (ftf) through flashtool, don't connect device immediately.

Open flashtool, select ftf and hit start.
Wait until flashtool say "connect device"
Then plug usb cable while holding vol down.

That way you'll prevent device to restart while it's waiting flashtool to prepare ftf...

Sent from my C6903 using Tapatalk
The Following User Says Thank You to funky0308 For This Useful Post: [ View ] Gift funky0308 Ad-Free
27th September 2014, 08:02 PM |#12  
Junior Member
Thanks Meter: 0
Originally Posted by trpincek

Hi guys, I'm new with Xperia phones and also new with rooting,flashing and using recoverys..

I installed a new rom on my device (iHackers rom). When i started installing I had like 25% of battery. When I finished the installation (I didn't flash recovery again because I did that with the help of my computer before, so file - zip was not on my phone) I rebooted my phone. So here's where the problem begins. My phone wouldn't turn on. Black screen all the way. Tried the red button near the SIM card, tried power button and volume up/down, tried power button..nothing powered my phone on, but vibrations were there. The red LED is blinking when i charge the battery (idk if it's even charging). If I take the phone out of the charger, the red LED stops blinking. I can't turn my phone on or get into the recovery mode even after 20 minutes of charging on 220v.
Guys please help..I'm in panic here.

I have similar problem, but my battery is still over 85%, and i got this problem when i try to flash cwm recovery with fastboot... what should do?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes