FORUMS
Remove All Ads from XDA

[APP][2.3+] Lux Auto Brightness

599 posts
Thanks Meter: 652
 
By Cyb3rGlitch, Senior Member on 19th October 2012, 11:58 AM
Post Reply Email Thread
25th September 2014, 05:38 PM |#1591  
Senior Member
Thanks Meter: 25
 
More
Samsung Galaxy S5, non rooted. Lux Pro 1.99.992.
I use the app with periodic mode.
In low light conditions I'm quite happy with Lux pro but in light conditions I don't understand how it works.
Lux lets me configure brightness as a function of Lux value.
My understanding is that Lux value is a function of data from light sensor.
With some testing I found the following:
Sensor reading 0..ca.5000: Lux value = Sensor value
Sensor reading ca. 5000..>100000: Lux value = 5008 constant!!!

Sensor values above 5000 are normal values in daylight. Sensor values ca. > 100000 are normal values in bright sun light .
But I can't make use of this information because Lux app limits the Lux value to 5008.

Anybody else with similar observations?
 
 
28th September 2014, 04:52 AM |#1592  
randomvector's Avatar
Senior Member
Flag London
Thanks Meter: 31
 
More
Lux and Tasker
Having problem where I trying to get Lux to turn on Display if the phone is ringing. I manage to set the Event (Phone Ringing) but when I select the Lux Plugin, once I have made my configurations then back out I get the Error toast: Error no plugin configuration data. Have tried over and over to find a way round this to no avail. Any help?
28th September 2014, 05:04 AM |#1593  
Member
Thanks Meter: 14
 
More
Are you trying to load custom settings just while the phone is ringing (what specifically are you trying to customize)? Which version of Lux do you have? I tested it with 1.95.
30th September 2014, 10:19 AM |#1594  
Mistertac's Avatar
Recognized Contributor
Flag Springfield, Ma
Thanks Meter: 2,776
 
More
The latest update to Lux bring any issues to anyone else? Seems Lux just doesn't want to work correctly on my G3 now .

I've wiped out my profiles, uninstalled and reinstalled and nothing.. I'll have to try and earlier release this morning at work and see what's up

- Tapatalked From The G3 -
30th September 2014, 12:22 PM |#1595  
Cyb3rGlitch's Avatar
OP Senior Member
Thanks Meter: 652
 
More
Apologies to everyone for not being around lately. I've been answering support via email.

A new release is rolling out on the market to 5% of users. Please use the 'Send Feedback' button in Lux preferences if you experience issues. Also, feel free to email me with any questions or concerns.
The Following 9 Users Say Thank You to Cyb3rGlitch For This Useful Post: [ View ] Gift Cyb3rGlitch Ad-Free
30th September 2014, 02:19 PM |#1596  
Senior Member
Thanks Meter: 7
 
More
I have a problem with LUX and cm11 for S3 Mini:
the inability to press "allow" when prompted me to superuser/supersu root access by applications.
I am forced to end the dashboard of Lux.
Are there solutions? Thanks!
The Following User Says Thank You to pleto For This Useful Post: [ View ] Gift pleto Ad-Free
30th September 2014, 02:32 PM |#1597  
Cyb3rGlitch's Avatar
OP Senior Member
Thanks Meter: 652
 
More
The update rolling out now should fix that... for now. Android L completely breaks the 'sleep list' and compat modes of Lux, so eventually you'll have to manually pause Lux.
The Following 2 Users Say Thank You to Cyb3rGlitch For This Useful Post: [ View ] Gift Cyb3rGlitch Ad-Free
30th September 2014, 04:24 PM |#1598  
Senior Member
Flag San Jose
Thanks Meter: 182
 
More
I've had issues after installing 1.99.993. Lux would give me readings of 0 lux no matter what light. I checked ignore 0 lux readings but it still functioned the same, no change in behavior. Always getting 0 lux readings.

I restored a backup of an older version so I can keep using lux.

Does anyone else have similar issues? I guess I'll have to wait for the next update and how it works.

Galaxy S4 w AOSP ROM 4.4.3.
The Following User Says Thank You to marbertshere For This Useful Post: [ View ] Gift marbertshere Ad-Free
1st October 2014, 10:49 PM |#1599  
trjlive's Avatar
Senior Member
Flag Los Angeles / Orange County, CA
Thanks Meter: 2,078
 
Donate to Me
More
Quote:
Originally Posted by Mistertac

The latest update to Lux bring any issues to anyone else? Seems Lux just doesn't want to work correctly on my G3 now .

I've wiped out my profiles, uninstalled and reinstalled and nothing.. I'll have to try and earlier release this morning at work and see what's up

- Tapatalked From The G3 -

You really need to be more specific if you expect any help. Just saying that you're having "issues" and that it "doesn't work" is very cryptic and useless to anyone trying to help you. Please be very specific: what exactly doesn't work? What are these "issues"?
The Following User Says Thank You to trjlive For This Useful Post: [ View ] Gift trjlive Ad-Free
2nd October 2014, 01:45 AM |#1600  
Mistertac's Avatar
Recognized Contributor
Flag Springfield, Ma
Thanks Meter: 2,776
 
More
Quote:
Originally Posted by trjlive

You really need to be more specific if you expect any help. Just saying that you're having "issues" and that it "doesn't work" is very cryptic and useless to anyone trying to help you. Please be very specific: what exactly doesn't work? What are these "issues"?

Sorry my friend I forgot I had even posted that. I was half asleep and In a pissy mood. I usually know better.

It seemed after the latest Lux update that my Auto Brightness was just all over the place, not behaving at all, one minute bright next way to dark, not following my profile at all.

Im a long time lux user so I somewhat know the tricks to these things and to be honest with you I uninstalled lux a couple of times and installed again, And now it seems to be working once again.

Im on a G3 stock rooted ROM so I either thought it was a Lux bug or maybe my phones sensors even... At this point it doesn't matter. Lux is working just like it always has for me, very well. Must have just been something odd on my end.

- Tapatalked From The G3 -
The Following User Says Thank You to Mistertac For This Useful Post: [ View ] Gift Mistertac Ad-Free
2nd October 2014, 11:46 AM |#1601  
trjlive's Avatar
Senior Member
Flag Los Angeles / Orange County, CA
Thanks Meter: 2,078
 
Donate to Me
More
Quote:
Originally Posted by Mistertac

Sorry my friend I forgot I had even posted that. I was half asleep and In a pissy mood. I usually know better.

It seemed after the latest Lux update that my Auto Brightness was just all over the place, not behaving at all, one minute bright next way to dark, not following my profile at all.

Im a long time lux user so I somewhat know the tricks to these things and to be honest with you I uninstalled lux a couple of times and installed again, And now it seems to be working once again.

Im on a G3 stock rooted ROM so I either thought it was a Lux bug or maybe my phones sensors even... At this point it doesn't matter. Lux is working just like it always has for me, very well. Must have just been something odd on my end.

- Tapatalked From The G3 -

No worries, glad you got it working again!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes