Remove All Ads from XDA
Honor 9 Lite

[Q] Jiayu G4S How to unbrick ?

41 posts
Thanks Meter: 10
By godhamer, Member on 25th June 2014, 10:42 PM
Post Reply Email Thread
Today I tried to change ROM. But something goes wrong I followed all instructions but apparently I pushed Format + Download now does not want to boot. May be it is bricked.
Everything is installed correctly !
Drivers, SP_Flash_Tool_v5.1348.00, Stock ROM from official web site.
I get these errors:
Firmware Upgrade error
Nand flash not detected

If you need more information about the problem I will try to explain.
27th June 2014, 12:56 AM |#2  
Junior Member
Thanks Meter: 1
The same problem
Hi, seems to be the same with my phone.
Maybe preloader file is not siutable? I think if I would unthick preloader file while I was trying to flash it would be fine. Maybe we need proper preloader file from factory ROM. Anyone who has original working G4SL 1GB/4GB could do flashable backup using MTK Droid Tools and post it somewhere please? It would probably unbrick our phones. Tutorial and download links here for example . Thank you in advanceā€¦.

If no and there is problem with accesing NAND flash... I don't know what we can do...format it? Set proper size somehow?
There was similar problem with MTK6577 here
I tried this SPMultiPortFlashDownloadProject but it doesn't load any configuration files...

Some one with ideas, please?
28th June 2014, 03:48 AM |#3  
Junior Member
Thanks Meter: 1
It works!
Hi It was problem with wrong ROMs. Yesterday they release new ROM on needrom + new SP Flash tools and was no problem to install everything It works again.
16th July 2014, 04:25 PM |#4  
Junior Member
Thanks Meter: 0
I have the same problem
Did you make?
6th October 2014, 10:50 AM |#5  
Junior Member
Thanks Meter: 0
I have the same problem. Can anyone help please.
I Have also bricked my Jiayu G4S.
I have tried Flasking latest Rom from NeedRom with Latest SP Flash Tool and also tried other versions from NeedRom but still get this error.

I have a previous backup of working rom on my SD from a Recovery Backup. Can this help in any way.

Phone currently not switching on.

Any Help appreciated.
Attached Images
File Type: jpg 4032.jpg - [Click for QR Code] (29.6 KB, 255 views)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes