Remove All Ads from XDA
Honor View 10

"Failed to create the account" ActiveSync error

15 posts
Thanks Meter: 0
By ek001, Junior Member on 11th June 2014, 05:32 AM
Post Reply Email Thread
Trying to set up HTC One M8 (Verizon) with my corporate ActiveSync account and having a miserable time.

1. I go to Settings-> Accounts & Sync -> + -> "Exchange ActiveSync" -> Manual Setup
2. I enter all my settings and credentials (see Screen1)
3. The device checks my credentials with the server (I see it in the server logs) and presents me with Screen 2. I click Next.
4. I type a name of my ActiveSync account and click "Finish Setup". This is when I typically get a prompt that I need to allow this device to be controlled by ActiveSync policy, etc (on other devices).
5. I get an error "Failed to create the account. Please try again later" (see Screen 4).

Exchange server logs indicate that the provisioning is not occurring (Code 142 stands for "DeviceNotProvisioned").

RequestBody :
<?xml version="1.0" encoding="utf-8" ?>
<Settings xmlns="Settings:">
<OS>Android 4.4.2</OS>
<PhoneNumber>Not Available</PhoneNumber>

AccessState :

AccessStateReason :

ResponseHeader :
HTTP/1.1 200 OK
MS-Server-ActiveSync: 15.0

ResponseBody :
<?xml version="1.0" encoding="utf-8" ?>
<Settings xmlns="Settings:">

ResponseTime :
06/10/2014 22:08:48

A few more pieces of info:

* I have a Nexus 10 tablet running 4.4.3, an Asus P1801 tablet running 4.2.1 and a Moto X phone running 4.4.2 - all devices work perfectly with the same settings/credentials.
* We have both Exchange 2013 and Exchange 2007 servers and I tried using an account on both - getting the same error.
* Our default Exchange policy requires device encryption, but I created several test policies that do not require either passwords or encryption - getting the same error.
* Our ActiveSync policies allow non-provisionable devices.
* I am using client certificates (issued by a private corporate CA) for ActiveSync authentication.

I tried to call Verizon and HTC - both support organizations are clueless. I cant even see email debug logs on the device because HTC's proprietary email client does support enabling debugging (via using d@d.d username).

Please help. I really like this phone, but without ActiveSync email support its as good as a doorstop to me, so I will have to return it.
Attached Thumbnails
Click image for larger version

Name:	Screen1.JPG
Views:	820
Size:	37.6 KB
ID:	2791844   Click image for larger version

Name:	Screen2.JPG
Views:	757
Size:	41.8 KB
ID:	2791845   Click image for larger version

Name:	Screen3.JPG
Views:	645
Size:	29.7 KB
ID:	2791846   Click image for larger version

Name:	Screen4.JPG
Views:	701
Size:	31.3 KB
ID:	2791847  
11th June 2014, 04:53 PM |#2  
GermanGuy's Avatar
Senior Member
Flag Minneapolis
Thanks Meter: 152
try to put in "master" for domain (without the "")
11th June 2014, 06:41 PM |#3  
OP Junior Member
Thanks Meter: 0
Originally Posted by GermanGuy

try to put in "master" for domain (without the "")

I tried what you suggested and could not even get past Screen 2 (where I type in my credentials). I get an error "Authentication failed. Please verify username and/or password.

This makes sense because my ActiveDirectory domain name is different.
21st October 2014, 11:21 AM |#4  
Junior Member
Thanks Meter: 2
I've updated my firmware today to enable the new HTC software, the mail app has been updated to 8.1.810518 and you can now proceed past this error.
It warns you that policies will need to be applied to the Exchange server, however I had this working on my HTC One M7, I'm an Exchange Domain Admin and I can now bin off that bloody aweful Airwatch client

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes