Remove All Ads from XDA

Solved: Wifi password not remembered

8 posts
Thanks Meter: 7
By bregol, Junior Member on 30th April 2014, 01:44 AM
Post Reply Email Thread
Just ota updated my wife's DNA (stock, unrooted) to KitKat over the past weekend. Now I'm finding that the home wifi has been forgotten on the phone (though other access points are still remembered) and even though I can reconnect it by typing in the password (which is rather long), when the wifi is turned off and on again, it is not remembered. I tried clearing cache, but that didn't help.

Anyone have any suggestions? I'm trying to avoid a factory reset, but am thinking that if something was wrong with whatever file the wifi passwords are saved in, that might be the only way to fix it... or then again it could be some other reason and a factory reset would be a huge waste of time.

Other devices are staying connected just fine. My own Droid Maxx didn't have this sort of issue when it updated to 4.4.0... Does the DNA's 4.4.2 just cause corruption that a factory reset would fix, or is there some sort of known bug that could be causing this. Not sure what my next step needs to be.

EDIT: Solved. Looks like my wifi password, while less than the 63 characters that should be the maximum for WPA2 is actually too long for the DNA to like under 4.4.2. I'm thinking there is a bug in 4.4.2 (or at least HTC's implementation of it) that limits the wifi password maximum characters below 63. In running some tests, it looks like it will only save the password if it is less than 50-55 characters (somewhere in that range, didn't narrow it down more than that). Once I reduced my wifi password length slightly, it worked just fine.
The Following User Says Thank You to bregol For This Useful Post: [ View ] Gift bregol Ad-Free
3rd July 2014, 04:25 PM |#2  
Drunkula's Avatar
Senior Member
Flag Denton, TX
Thanks Meter: 65
I was going crazy with this the past week. Since your details sound exactly like what mine is doing this must be what is happening to me. Odd, though, that it just started happening as I've been on 4.4.2 since it came out and it just started happening.

I can't verify right now (not at home) but will try soon as I can. Thanks!
8th July 2014, 12:25 AM |#3  
Drunkula's Avatar
Senior Member
Flag Denton, TX
Thanks Meter: 65
Well still no go. I'm down to around 50 characters and it still won't remember. Getting tired of chopping 5 characters off every time. It's a pain in the ass to correct the WiFi settings on my PS3, too. I may just forego not having WiFi at home, unless I paste the password in when I need it.

Not sure yet but using WiFi Manager (from Play Store) seems to work. Also it appears other devices are having the same exact problem.

WiFi Manager did not help.
28th October 2014, 06:31 AM |#4  
Junior Member
Flag Phoenix, AZ
Thanks Meter: 17
I was able to fix this, though it requires root. Passwords are saved in /data/misc/wifi/wpa_supplicant.conf.

They are normally unencrypted under Android, but HTC has an extension that encrypts them. However, the HTC code doesn't seem to like long passwords. The "psk=" line seems to be broken into two lines, but should only be one.

Joining the lines doesn't seem to work, so I just put in the unencrypted password as

psk="My Secret password"
31st October 2014, 07:03 PM |#5  
Drunkula's Avatar
Senior Member
Flag Denton, TX
Thanks Meter: 65
Yeah I'm not sure what the cutoff on size is. I'm currently using a 32 character passphrase. It saves that!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes