Remove All Ads from XDA
Honor View 10

[Q] 64gb Micro SD Write Protected/Read-Only After Flashing a Rom [Please Help!]

313 posts
Thanks Meter: 40
By kevin95, Senior Member on 10th February 2014, 05:01 PM
Post Reply Email Thread
I have a M919V Galaxy S4 which is compatible with both the i9505 roms and M919 (TMO) roms. I was on a i9505 TW rom and I decided to download a rom from the TMO section. When moving from a i9505 rom to a M919 rom, I had to flash the recovery corresponding to the model. So I downloaded the T-Mobile version of Philz Recovery, but I got a status 7 error. Then I downloaded the md5 version and flashed it via odin 3.07. It was successful. After flashing the recovery, I flashed Beanstalk rom for the t-mobile variant. Everything went fine until I tried to make a nandroid of my current setup for Beanstalk. I kept getting errors. When I plug my phone in (with my sd card), and try to add or delete something, it says "remove write protection and try again". So I tried connecting my sd card to my sd card adapter. When I delete files from my adapter, the error message doesn't show up. BUT... after disconnecting and reconnecting it again, the files are back where they were. I tried reformatting it but nothing happens. It seems like my sd card is only read as write protected when connected to my phone but it has no idea which state it's in when connected to the sd card adapter.

I don't know if the problem started with odin or when I flashed the rom but can anyone please tell me what's going on with my sd card?
10th February 2014, 10:05 PM |#2  
kevin95's Avatar
OP Senior Member
Thanks Meter: 40
30th August 2014, 03:03 PM |#3  
Thanks Meter: 6
i have the same problem, 64GB sandisk, now write protected... need a solution
30th August 2014, 03:13 PM |#4  
Junior Member
Thanks Meter: 0
i see u got a funny problem . when you connect sd card to adaptor, do u check unread only in his property? after format, all file has been recovered or just some file?
18th December 2014, 11:47 PM |#5  
Junior Member
Thanks Meter: 3
i have the same problem, 64GB sandisk, now write protected.
need help
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes