Remove All Ads from XDA

[FIX] Data Encryption Problem AOSP Roms

951 posts
Thanks Meter: 396
Post Reply Email Thread
2nd September 2014, 09:09 AM |#71  
Darknites's Avatar
Senior Member
Thanks Meter: 2,594
Originally Posted by vince47

Well Saturday I installed cm-11-20140830-NIGHTLY-m8 to try it out (came from CleanROM 1.4) At the end of the day I decided to go back to cleanrom so I tried to restore my nandroid from TWRP. -ERROR- could not mount data within TWRP. Found this thread and tried the command in ADB Shell. Still couldn't mount DATA (internal SD). I ended up formatting data from within TWRP and then was able to restore my backup. I did not use the power and volume up to reboot so I don't know what would have caused the encryption problem but at least I'm functioning again. Thank you all for providing your valuable input.

Ya i kinder had this, couldn't see internal sd but after trying many things it seemed wiping caches fixed it for me.

Sent from my One M8 using Tapatalk
5th September 2014, 07:15 PM |#72  
Senior Member
Thanks Meter: 41
Not sure if it was posted in the thread, but I've had this happen to me before and all I did was a RUU and it fixed it. Maybe that's an alternate method you guys having problems can use.

I'm on Verizon btw.

Sent from my One M8 using XDA Free mobile app
19th September 2014, 03:17 AM |#73  
fix-this!'s Avatar
Senior Member
Flag midwest
Thanks Meter: 714
Is this rom or kernel related? Just had this on aicp + furnace kernel. What causes it and why hasnt a permanant fix been implemented?
20th September 2014, 05:28 AM |#74  
S1L3nTShaDoWz's Avatar
Senior Member
Thanks Meter: 91
I have an alternative solution that just saved me.

A few weeks ago someone posted in a thread I was replying to about having a special version of TWRP called "Buck's TWRP" and I downloaded it and have been using it since, now before someone blasts me about this, I have no idea who's TWRP this is or if it's the normal one but all I know is I never had these features I'm about to mention before I installed it. Anyways I flashed that a while back when I found it and came to like it quite the bit more so kept using it. Today I did the Vol up + Power and encountered this when, it happened right after flashing the brand new CM nightly that came out 9/19 (today).

Anyways onto the solution that fixed it for me.

1) in Buck's TWRP go to > Wipe > Advanced Wipe > Repair Filesystem or change Filesystem > Change Filesystem
2) Change it to Exfat4 or whatever you already have (should tell you above it) and then navigate to 'Repair Filesystem' and repair it.
3) After having done those steps it should've passed/completed all of them with no errors and your /data should now be mountable with no data losses.
4) Restore a Nandroid of your old ROM or whatever you want and be glad you didn't lose your pictures/music/internal storage (if it worked)

Lastly, yes I know saying "special" makes it sound shady, but take my word for it it worked for me and is worth a shot. Will link it below and if anyone can tell me who made this and or link me to the original download link I'll credit them and link to their thread or whatever they have. For now all I know is it was called and named "Bucks TWRP" and I found it on another forum after failing to find anything else on Google.
Oh and this may be in the newer TWRP's, not exactly sure as I haven't tried them but I'm just posting this from what I myself did.

Download link file exceeds limit and can't upload on-site.
Edit: Never mind, normal TWRP has the feature, I just never noticed it as I was never looking for new features until I flashed that. Still it solves the encryption bug or at least it did for me and also solves other problems with an unmountable partition (system, data, cache, etc)
22nd September 2014, 03:51 PM |#75  
maxrdlf95's Avatar
OP Senior Member
Flag Caracas
Thanks Meter: 396
Donate to Me
That feature its already on twrp and once you restore or fix data you can boot into current rom
1st December 2014, 07:14 AM |#76  
nxsone's Avatar
Senior Member
Thanks Meter: 217
This saved me twice already once in kk and now on lollipop , I flashed one of the unofficial cm12 Roms and ended up encrypted and this simple method worked again thanks to OP really saved me .

Sent from my HTC One_M8 using Tapatalk
21st December 2014, 11:09 PM |#77  
Junior Member
Thanks Meter: 0
Fix did not work. Error message from ADB in comments
Here is the error ADB is showing me. I'm not able to wipe, restore file system, or change it. I've been scouring the forums trying to find more help. Please forgive me if I missed a thread.

Error reading block 14389 (Attempt to read block from filesystem resulted in sho
rt read). Ignore error? yes
Force rewrite? yes
Error reading block 14390 (Attempt to read block from filesystem resulted in sho
rt read). Ignore error? yes
Force rewrite? yes
Error reading block 14391 (Attempt to read block from filesystem resulted in sho
rt read). Ignore error? yes
Force rewrite? yes
Superblock needs_recovery flag is clear, but journal has data.
Run journal anyway? yes
e2fsck: unable to set superblock flags on /dev/block/mmcblk0p47
~ # e2fsck -f -y /dev/block/mmcblk0p47
e2fsck 1.41.14 (22-Dec-2010)
/dev/block/mmcblk0p47: recovering journal
28th December 2014, 11:23 PM |#78  
Senior Member
Flag Pueblo
Thanks Meter: 57
Originally Posted by maxrdlf95

e2fsck -f -y /dev/block/mmcblk0p47

Big ups to OP for this. I have had the encryption bug happen to me about 3 or 4 times now in the last couple months, all while trying to flash cm12 based roms, and each time, I would just RUU back to Developer Edition and start all over. A big, time consuming pain. I happen to get the bug today while flashing and when I ran this method, everything worked amazing. None of my data was lost, and I was able to reboot back into Multirom.

Thanks so much for this info!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes