Remove All Ads from XDA

[Q] TF101 Completely dead

5 posts
Thanks Meter: 0
By fholtsberg, Junior Member on 26th January 2014, 02:06 AM
Post Reply Email Thread
So my TF101 appears to be completely dead. I had it rooted and rom'd running KatKiss 4.3,not sure of which number . I loved it too. Anyway, before it died, it rebooted and would not leave the "updating apps"screen so I did a factory install which fixed the problem but only temporarily. A few days later the same thing happened. This time I could not even reboot it. I left it charged overnight but could not get it to boot at all. I think I have tried everything. I tried booting with and without being on the keyboard dock, I have tried plugging into the computer, tried hdmi to a monitor to see if the screen went bad. I tried seeing if the computer recognized it in APX mode. NOTHING. The USB charges the keyboard dock but does nothing for the tablet. The computer does not see it period. It looks completely dead. It is out of warranty but I even called ASUS and all they would do is charge me $340 to send it in.

I would love to troubleshoot to see if it is a board or battery or whatever gone bad , but I cannot find anything on the Web. Can anyone help. Otherwise it's a lovely paperweight.
26th January 2014, 10:57 AM |#2  
*Detection*'s Avatar
Senior Member
Flag Durham
Thanks Meter: 1,940
Donate to Me
It's possible that the battery has come to the end of it's life and won't hold any charge, which would explain why APX mode won't work, the PC can't power on the TF via USB, only trickle charge it while it's powered off / screen is off, but if the battery is dead then that's not gonna happen either

Not sure if the charger needs the battery for it to power on the TF too or not

You could try disconnecting the battery and plugging in the charger

Here is a good teardown video to show exactly how to get that done

Im not 100% sure, but if the dock battery is fine, you could check and see if the connections are the same and swap them over

15th March 2014, 10:56 PM |#3  
OP Junior Member
Thanks Meter: 0
Still DEAD
Thanks for the awesome YouTube of breaking down the TF101. Unfortunately, I swapped batteries and still no good. Nothing happens. It looks like the old battery has power too, based on my multimeter. Is there anyone else with suggestions at this point or do I leave it as a nice paperweight?

31st December 2014, 06:16 AM |#4  
Senior Member
Thanks Meter: 27
Apologies for resurrecting this thread. My TF101 (with dock) had also gone dead after running one of the KatKiss ROMs (maybe 4.2). Wouldn't charge, wouldn't turn on even to the bootloader or recovery. Charged it for days, nothing. I left it for dead and forgot about it for over 6 months. Uncovered it the other, dusted it off, charged it and it magically powered up. Everything was still on the tablet as it was before it went unresponsive.

My guess is that a microcontroller responsible for powering up the tablet got into a bad state. Even when powered off, these very low power microcontrollers remain on to handle the button press that powers on the device. It took the tablet being absolutely, fully discharged to clear it out of that bad state. Not just 0% as reported by the battery firmware, but a true complete emptying of the battery where its voltage drops below what the microcontroller needs to remain running.

Hopefully if you still have the TF101 after all this time, try charging it up all the way and see if it comes back to life.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes