Remove All Ads from XDA

Unable to charge!

229 posts
Thanks Meter: 21
By siciliano777, Senior Member on 8th January 2014, 12:14 PM
Post Reply Email Thread
19th January 2015, 01:42 AM |#11  
donc113's Avatar
Senior Member
Thanks Meter: 189
Originally Posted by wasim salman

I had this problem for some time now
it used to happen once every few weeks
now the phone doesnt charge using the original usb 3.0 cable provided with the device
I have no idea whats the problem
I plug it in and yet battery still goes down
leave it for hours and its not fully charged
and keels disconnecting
tried another cable, still the same problem
am out of the states and so, no verizon tech support
any ideas ??

Try a different USB power source (charger). They should be available worldwide.

Sent from my Note 3 via Tapatalk
The Following User Says Thank You to donc113 For This Useful Post: [ View ] Gift donc113 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes