Remove All Ads from XDA
Honor View 10

GPS locating every time you use google voice typing. (microphone button) Solution

121 posts
Thanks Meter: 49
By k00zk0, Senior Member on 10th June 2014, 04:19 AM
Post Reply Email Thread
Hi all,

I use a Galaxy S3 T999 and across several different 4.3 ROM's, I've found that since about a month ago, every time I hit the microphone key on the keyboard to voice type, the GPS icon will display for about 4 seconds. I don't know why this is necessary, any input?

So, if this bothers you (privacy, battery life?) here's the solution I found:

First, trying to control location permissions for this will block all location access otherwise. You must disable location permissions for Google framework which will also stop location from working in maps, etc.

The solution I found is to uninstall the update to the "Google Search" app, and check the box to stop it from auto-updating. I see zero performance impact or functionality loss, and no loss of accuracy in voice typing, for my purposes (I don't use the Google Search app or Google Now). The voice typing process uses about 10% less cpu while it is listening to your voice too.

The Google Search app, as far as I know, provides the functions of Google Now. Using an old version means you'll be missing some cards and perhaps some other functions. Since I personally don't use Google Now, this solution works for me and hopefully for someone else.


Does your gps icon blink for a bit every time you hit the microphone key (on the keyboard) to voice type? I found not every device is doing this.

The Following User Says Thank You to k00zk0 For This Useful Post: [ View ] Gift k00zk0 Ad-Free
23rd September 2014, 07:17 AM |#2  
Junior Member
Thanks Meter: 0
Thumbs up It worked - Thank you!
Thanks a ton! Your fix worked, this location stuff was bothering me. Looks like not many are bothered by the GPS locating happening everytime the Google Voice Typing is opened or is it just a few phones plagued. I am on a Galaxy S3 (i9300) running CM10.2.
3rd February 2015, 03:51 AM |#3  
Senior Member
Thanks Meter: 15
This seems to be a T999 issue
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes