Remove All Ads from XDA

How to root xolo x900

9 posts
Thanks Meter: 0
By dr.arun, Junior Member on 13th May 2014, 08:04 AM
Post Reply Email Thread
hello there can any one help me to root xolo x900 i had tried every thing that is available in internet every thing failed is there any way to root it
Attached Thumbnails
Click image for larger version

Name:	IMG_20140508_110536.jpg
Views:	193
Size:	271.6 KB
ID:	2740984  
13th May 2014, 01:24 PM |#2  
Junior Member
Thanks Meter: 1
First make sure you have the following

- Xolo ICS update installed.
- Intel USB driver for Windows
- The Root Installer

- Enable USB Debugging mode and then connect your Phone to PC.

- Extract root installer archive and run the runme.bat file.

- In your PC, type 1 in the command prompt for “Make a choice”. your device will ask for Full Restore. You will not loose data. Select Restore my data. Finally, your device will reboot twice and you will be rooted. Note that your screen may flash before the second reboot which is fine.
3rd November 2014, 06:42 AM |#3  
madsurgeon's Avatar
Senior Member
Thanks Meter: 280
Managed to Root my xolo x900
I think I've found a way to root my x900. It's currently running the latest version of SuperSU 2.16 and has the stericson busybox installed.

I've tried rooting the x900 with all possible methods and have never been successful. Especially the part where it says 'restore started' then 'restore ended' almost immediately. By no means am I an expert on this and the following was achieved with a lot of trial and error, I've tried to put it down in the simplest way I could.

Warning: Try the following at your own risk.I do not wish to be held responsible for any damage your phone might incur.

These were my steps:

1.I extracted the boot.img(a) from the orange-sandiego ics signed update file found at modaco forum

2. I extracted the boot.img(b) from the official rom downloaded from androidxda.

3. Download and install minimal adb and fastboot installer from XDA forums along with the Intel-usb and adb drivers from androidxda.

4. Download the latest Superuser binary and .apk .zip from the official XDA thread

5. Download the stericson.busybox.apk from the internet.

6. Place the boot images[(a) and (b) renamed to your preference] in the main folder of the minimal adb/fastboot exe, found in C: program files x86...... Also unzip the SU file and place su from the x86 folder and the Superuser.apk into the main adb/fastboot folder along with the busybox.apk.

4. Turn on usb debugging and switch off the phone.

5. Hold vol-up + power keys for about 10seconds to put the phone into bootloader mode. It should say 'droidboot' on the screen.

6. Open a command prompt from the adb/fastboot desktop shortcut you have after you're done installing the adb/fastboot exe.

7. Type in

fastboot devices

Your device will be listed, then type in

fastboot flash boot boot.img(a)

This will flash the boot.img from the orange-ics-update, then type

fastboot reboot

Your phone should now reboot to system but the screen will not be functional and will only show different colors.

8. Now type

adb devices

To confirm your device is visible. Follow this with:

adb shell
mount -o rw,remount /system
adb push su /sdcard/su
adb shell
cat /sdcard/su > /system/xbin/su
ln -s /system/xbin/su /system/bin/su
chmod 6755 /system/xbin/su
adb install Superuser.apk
adb install stericson.busybox.apk
adb reboot bootloader

9. Now once again after confirming that the device is recognized in fastboot do this:

fastboot flash boot boot.img(b)
fastboot reboot

Your phone will now reboot to system, and it will have root access and busybox installed.

Good Luck.
3rd November 2014, 06:55 AM |#4  
Senior Member
Thanks Meter: 5
You user framaroot v 1.9
3rd November 2014, 01:29 PM |#5  
madsurgeon's Avatar
Senior Member
Thanks Meter: 280
Originally Posted by 0967894983

You user framaroot v 1.9

I've tried all versions of framaroot before, none worked, neither does towel root, cydia impactor, v-root or shuame root helper.
12th February 2015, 03:15 AM |#6  
Junior Member
Thanks Meter: 0
Wicked! Thanks for that.

Are you able to install a full Linux distro on the device after it is rooted or is the bootloader still locked?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes