Remove All Ads from XDA

dirty sandisk 64gb Sd card volume on galaxy note 2

196 posts
Thanks Meter: 11
By sifat004, Senior Member on 6th January 2014, 09:07 AM
Post Reply Email Thread
Hello all..I am facing a weird problem of my sandisk 64gb class 10 card. Suddenly I cant copy anything on it. Its in exfat format. I have tried to format it using card reader but couldnt. Even I tried to format it by phone. But not working.

I can access it but cant delete anything or format.

Plz someone help as I have no warranty as purchased from other country.

Thanks in advance.
25th March 2014, 12:37 AM |#2  
Thanks Meter: 0
hi! try sending an email to sandisk. i faced the same issue before and when i sent them an email, they had me mail them the sd card and they sent me a new one. the only thing you need to pay for is the shipping in sending them your faulty card. they're going to shoulder the shipping in sending you a new one. haven't really found a way to resolve the issue, though, but i hope this helps.
26th March 2014, 05:03 AM |#3  
as amPOGlko said... try returning it. There's a lot of sites saying the same thing... sandisk and samsung phones not working well together. Who knows?
If they don't send you a new one, then maybe you can try Samsung or Toshiba SDcard instead. Good luck!
15th February 2015, 04:49 PM |#4  
Thanks Meter: 1
I am in the exact same situation, contacted sandisk and they said that a small percentage of 64gb sdxc cards suffer from this issue. They also can change the faulty one but I lost my confidence in this brand, because forums are full of problems related to sandisk 64gb used in Note series.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes