Remove All Ads from XDA

[APP][4.4]FIXED: Rsync failed to set time on file on KitKat with SD Card Fix in place

28 posts
Thanks Meter: 21
By wfire, Junior Member on 25th May 2014, 02:42 AM
Post Reply Email Thread
There have been lots of posts and articles and questions about the dreaded SD Card access changes in KitKat, and how the SD card can no longer be freely written.

And there is an excellent thread here about a great app that can fix it.

However, whether you fix your permissions manually, or using this app, there is still a very subtle difference.

I've been using rsync for Android for several years. I have a central Linux server at my house, on which I keep all my files, and I periodically rsync FROM my server, TO my Android Device (in this case, a Galaxy Note 3 SM-900 4G running 4.4.2) to a structure on the external SD card. That way I can keep a local copy of my files with me at all times. I pretty much fill a 64GB SD card this way.

Under 4.3 and earlier, I used /storage/extSdCard (or /mnt/extSdCard ) as my mount point to access my external SD card, and everything worked fine.

However, under KitKat, rsync was having a very strange issue. Attempts to rsync a file would result in:

rsync - failed to set time on file

for any file that it tried to transfer. It seemed like it was transferring the file, but was unable to change the timestamp on the file.

The solution turns out to be visible if you run Android Terminal Emulator and look at the output of the mount command. Tracing through that, I discovered that there is also a less-obvious alternate mount point, which is:


And, indeed, using that as an rsync target solves the timestamp problem.

Felt this should be posted somewhere, hope this is the right place.

The Following User Says Thank You to wfire For This Useful Post: [ View ] Gift wfire Ad-Free
25th May 2014, 03:24 AM |#2  
ktetreault14's Avatar
Senior Member
Flag Largo
Thanks Meter: 1,812
Donate to Me
Nice find bro!!

Sent from my SM-G900W8 using XDA Premium 4 mobile app
17th June 2014, 09:16 PM |#3  
Junior Member
Thanks Meter: 0
Amazing. Thank you.
8th March 2015, 03:07 PM |#4  
Junior Member
Thanks Meter: 0
I'm having the same problem on Lollipop and I don't have that mount point. I tried both /mnt/extSdCard and /storage/sdcard1 and both still get the error. Any ideas?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes