Remove All Ads from XDA

[Q] Download Mode on Kitkat?

548 posts
Thanks Meter: 426
By D<3'SJ2427, Senior Member on 8th June 2014, 02:16 AM
Post Reply Email Thread
I'm not able to get into download mode on T-Mobile stock Kitkat via having the phone turned off and plugging in USB cable. Was on JB, rooted, CWM, used LG flash tool to restore back to stock, factory reset then took the OTA'S to play around w/kitkat. Did not have the download mode issue while on D-FUSE rooted kitkat rom, was able to flash back to JB using flash tools, did I hose myself by taking the updates? I would greatly appreciate any help on this matter, thank you
10th June 2014, 10:44 PM |#2  
D<3'SJ2427's Avatar
OP Senior Member
Flag The Emerald One
Thanks Meter: 426
Download Mode on T-Mobile Kitkat
Not trying to bump my own post or anything like that, had a chat with LG and this is what I was told: 11:02 AM Joe: I see. Regretfully at the time it seems that for the updated software, Download mode is not available as this is used to perform operations that may be harmful to the device. In order to avoid this and therefore avoid system errors, the download mode is no longer supported on this product. Is there any way at all around this? I honestly dont know what I was thinking, should have just flashed D-FUSE ROM. Obviously from the first post not the sharpest tool in the shed, I'm not sure the steps to take or if I even can do anything through ADB to get download mode back, again I would greatly appreciate any help, thank you
7th April 2015, 07:35 PM |#3  
Junior Member
Thanks Meter: 0
Sorry to bump an old thread but I'm also having this issue.

I was rooted (stock) and performed a factory reset due to issues staying connected with towers.

I guess I dumbly updated my firmware while in the process of getting my phone back in order.

So I'm running 4.4.2 (KK) with a build number of KOT49I.D95920s (20s). Device is the T-Mobile D959

I know I need to get my firmware back to 10c in order to be able to root again but the problem is I cannot get into download mode (probably because of the firmware update.)

I have no recovery mode. I cannot use Freedom Flex to install one either because the phone is not rooted.

I can't use IORoot (I get to the part where I need to toggle the download mode and I can never proceed), towelroot isn't supported,
and stump isn't supported (nor does it offer me a brute force method; again probably due to my firmware version.)

I tried LG Root ( but can't get into download mode.

I have the valid KDZ file but since I can't get into download mode, I can't use the LG Flash tool (2014 or 1.0.54). I also have a valid .dll file.

I have not found a tot file.

I don't care what android version I'm using, I just want to have a recovery and root working again.

If anyone can please help, I would greatly appreciate it. I've been tearing my hair out.
7th April 2015, 09:05 PM |#4  
Junior Member
Thanks Meter: 0
Wow, I was finally able to flash and root my phone using this method:

I used the offline mode.
I grabbed the DLL and image from here:
I flashed the 10c build first, and it worked so I went ahead and flashed the 20h build to be able to use freedom flex to install cwm.

No more firmware upgrades for me!!!!

I sincerely hope this helps out anyone else with this issue.
21st June 2016, 08:30 PM |#5  
Junior Member
Thanks Meter: 0
downgrade 4.4.2 without download mode
just discovered this. you can use the lg flash tool with the phone on! without having to enter download mode. simply connect as lg software and run the program. successfully downgraded to d95910c this way
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes