Remove All Ads from XDA

Moto G 4g LTE - Sandisk ultra 32gb microsd card won't mount

12 posts
Thanks Meter: 1
By Arthemedus, Junior Member on 15th June 2014, 04:32 AM
Post Reply Email Thread
25th December 2014, 01:51 PM |#161  
Thanks Meter: 8
possible workaround tool
Hi guys,

I had the same problem with an 32gb class 10 card.
The following tool, available on play store, solved the problem for me:

Just mark the beta option "service".

23rd January 2015, 11:12 AM |#162  
Junior Member
Thanks Meter: 0
32 Gb SD Card problem here as well. SDFixtool gives me messages like, "Couldn't write on external SD Card, set path by yourself." It states that External SD: not mounted.
When trying to scan gives these error messages: "Something went wrong while indexing" and asks if my phone is rooted, which isn't so.

A little problem history: First I installed the 32gb card and moved some music on it and was happy that I had a lot of free space available for photos etc.
At one point I was confused when I recorded a video and it played fine for a while but afterwards got corrupted. A little mystery then. Since then I've tried many many times to add music on the card and mysteriously media players (google player and Shuttle) recognizes these tracks but Google player says that this track cannot be played and Shuttle gives 0.00 lenght for the track but still gives the album cover etc. So they recognize them right, but cannot play them.

Yesterday I started to really try to solve this mystery. I did several formatting on the card and rebooted phone and deleted cache from players and media etc. also several times. I tried three times to add like 15-20 gigs of music, which everyone knows is absolutely annoying because of the time it takes. Every single time same thing happens. I start playing music and it works fine. Then I try to play music further down the list and it works and then it happens. I'm going down in alphabetical order and suddenly it jumps like from F to N. When I checked my storage on phone, it was taking first like 25 gigs of space and after I tried playing music and noticed this weird jump on the band list. I then checked again the storage and now it was giving me about 25gigs of FREE space.

In conclusion: System or phone or whatever handles the card as it is around 8gb card and corrupts or cannot handle/understand etc. data that exceeds the ~8gb amount. Every single time I added 10+ gigabytes, it corrupts the data exceeding this 8gb.

If there is a solution for this, it would be greatly appreciated. I'm pulling hair here with this and am really annoyed that 32gb card, that SHOULD work as promised, is not working.

Stats: Moto G 1st gen, Kitkat 4.4.4, system version 21.11.56, SD card 32gb manufacturer unknown, but works fine with other devices.

Thank you for reading!
4th May 2015, 04:05 PM |#163  
Junior Member
Thanks Meter: 2
Having problem with my SD card as well. I'm using a Samsung 32GB Class 6 (!), with CM 12.1/lollipop 5.1.1 and it works for a while, but eventually it always unmounts and remounts, sometimes checking the card for errors.

After it has mounted/unmounted a few times it usually ends with it not detecting the SD card at all until reboot. I haven't ran into any corruption issues but what I got now is bad enough.

I tried reformating it several times with FAT32, but with the same problem.

Going to try another Samsung microSDHC card now, an 8 GB class 6 and see if that runs into the same problem, but I'm not hopeful.

Since this problem seems common, I guess the conclusion is that it's a common hardware problem that Motorola doesn't care about?
6th May 2015, 02:19 AM |#164  
Senior Member
Thanks Meter: 30
I had constant failures with Sandisk grey/red 16GB and 32GB. When I switched to an old black Sandisk 8GB I never had an issue again.
6th May 2015, 09:34 AM |#165  
Junior Member
Thanks Meter: 2
A little update, after switching to a samsung 8 GB card instead of 32 GB it's been working perfectly so far. Not a single error.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes