Remove All Ads from XDA

Tmobile US Sony Z1s Root Bounty ($670.00) CLOSED Root Achieved!!!

2,113 posts
Thanks Meter: 336
By epsix, Senior Member on 11th February 2014, 09:47 PM
Post Reply Email Thread
28th January 2015, 04:35 AM |#1321  
Thanks Meter: 2
Broken root
Originally Posted by jcase

Geez no one can get root working? Full details are posted everywhere. Fine, here.

Dear Sony, :/ sorry for violating my self imposed embargo, someone else outed the vulnerability and build exploits (See z2 root) based on google patches before August. It was happening with or without beaups and I. Either google needs a longer embargo, or us carriers need to be faster to allow updates.

If bounty still exists, please send to, I will split with @beaups and then dispense my half to the charity of my choice. If it doesn't, I hope everyone got their money back.

donations can also be sent to, please note what they are for so i can split them with beaups

adb push pwn /data/local/tmp/pwn

adb shell chmod 755 /data/local/tmp/pwn

adb shell /data/local/tmp/pwn
then wait until adb works agian, and then reboot

Someone else will have to setup a proper way to disable write to system, however running /system/xbin/ will disable ric and allow you to write to system until reboot. Until a better approach is setup, i suggest using some on boot app to run it as root.

You will need supersu app from the market. Dont ask me for support if you didn't follow directions, dont ask me for support unless it throws errors.

This rooting method appears to work and allows root apps, once installed, to request root access. They have limited abilities to function and many to not perform fully or at all. Titanium, for instance, thinks it is removing bloatware successfully. When in realty the software remains intact and untouched. SuperSU binaries will not install and the xprivacy process fails completely. I have reflashed the stock firmware with flashtool and gone through the process multiple times. The result is always the exact same. Is there a functional root method out there for the C6916 xperia Z1S? I have gone up to 4.4.4 in the mean time until a root method older firmwares can be found. The only 2 I have are a very old JB 14.2.C.0.159 and the new KK 14.4.B.0.56. I need a slightly older kernel to perform a functional root on and the kernel only FTF file from 14.4.B.0.56 to flash back on after root. Does anyone know where I can get a newer firmware with a reliable root method? Thanks to all who reply!
30th January 2015, 04:27 AM |#1322  
Junior Member
Flag Blanchard, OK
Thanks Meter: 1
Donate to Me
Having trouble
My adb is messed up or something, I copy each line of the code exactly and what happens is after entering the first line says "cannot stat 'pwn': No such file or directory" am I putting the file in the wrong place? Any help appreciated! thanks for helping!
13th March 2015, 04:57 AM |#1323  
rfunderburk39's Avatar
Senior Member
Flag NMB
Thanks Meter: 105
Donate to Me
Originally Posted by nickcaper

I found the method to root and also have dual recovery ..

It works on 14.3 and 14.4. I have tested them both thoroughly and it works.

For 14.4 you will need a SDcard fix to enable sdcard writing.
kitkatt 4.4 disabled the ability of apps to write to your sd card. I couldnt even delete stuff on my sd card. (wth were they thinking idk )

SO ill run down the basic road map to get you going.
1)Root with zxz0O0 Tool You might have to run it twice if it hangs under cleaning up
Thing to do to before you install, to make root work:
USB debugging enabled
Settings => About phone => Click 7 times on Android Build to unlock developer options
goto security, check on Unknown sources enabled
make sure adb drivers are installed so you can properly use the phone on your pc to install the tool
How to use
Download the tool and extract it
Start your device and plug it to your computer
Run install.bat and follow the instructions on screen
Congratulations! You should now be rooted.
2)Install SuperSU from market or from an apk apk, reboot.
3)Install Recovery Z1 Locked Bootloader. Use option 1 to install the recovery. Reboot. It may reboot into recovery. If it does, look for the option to reboot again. Let phone sit for a minute to run its course. Reboot, but this time test your recovery. Make sure the phone is unplugged. Power it on, When you feel the phone vibrate 2 times while the Sony Logo is showing, press the volume up button for CWM or volume button down for TWRP.
3)Download and save the Deodex patch Mega and flash threw recovery. Reboot. It will take a couple to re-initiate due to de-odexing.

Thats it... Youre done. You now have a rooted phone with dual boot. And it works flawlessly on 14.3 or 14.4.. Keep in mind De-odex is NOT for 14.3 so skip that step if you want to root 14.3

As for the Sdcard fix. Use FX file exporer in the play store. Install the root add-on and then install the sd card fix for it as well. You will beable to use your sd card as usual...

As for a custom rom.. forget about it...
This phone is locked. You dont need a custom rom anyway..
The rooted method with recovery is super easy and you can customize your phone the way you want, backup and restore it.

If your phone ever needs to be fully factory restored or if you soft bricked it....
just use the FLASH TOOL to install the factory TFT
The 14.4 TFT is HERE

Make sure you know how to use the flash tool before you take that dive...
If you need that tutorial GO HERE

Worked like a champ, now I have an Deodex ROM with much bloatware removed. Thank you very much
16th April 2015, 12:03 PM |#1324  
rob420p's Avatar
Senior Member
Flag Bmore
Thanks Meter: 16
I Know I'm goin to be vilified for this but are there any oneclick ota root possible or is there any new ones anyone could suggest been against a brick wall trying to root I'm good on a phone years of last nexus training lol.but I have no pc and I suck on the pc as crazy as that sounds. I miss the frama srs and etc days.
20th April 2015, 05:11 AM |#1325  
Senior Member
Thanks Meter: 223
Google towel root, try that. Been a while since I rooted mine, not sure if there's a one click root.
20th April 2015, 07:10 AM |#1326  
rob420p's Avatar
Senior Member
Flag Bmore
Thanks Meter: 16
Originally Posted by gqukyo

Google towel root, try that. Been a while since I rooted mine, not sure if there's a one click root.

Sadly doesn't work it don't seem like anyone click works anymore sadly
22nd May 2015, 03:09 PM |#1327  
Senior Member
Thanks Meter: 37
This method doesn't work anymore?

I've tried it , but still can't get root
30th May 2015, 11:17 PM |#1328  
rob420p's Avatar
Senior Member
Flag Bmore
Thanks Meter: 16
Use kingroot
1st November 2016, 05:13 PM |#1329  
Junior Member
Thanks Meter: 0
I know this is an old post, so I apologize in advance.

Does this root tool still work for the Z1s? I downloaded the zip file and extracted to desktop, but it doesn't seem to be recognized by my PC. Also, is there a custom version of Marshmallow available for this device?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes