Remove All Ads from XDA

[FIX] No Power Menu, No Lockscreen, Corrupt Efs FIX! Skyrocket and T989

2,722 posts
Thanks Meter: 785
By icenight89, Senior Member on 21st April 2012, 09:37 PM
Post Reply Email Thread
12th December 2013, 01:25 AM |#141  
Junior Member
Thanks Meter: 0
Thumbs up finally worked out! GT- I9305
Many thanks to OP! YOU SAVED MY BACON!!!!

Samsung Galaxy S III LTE - I-9305

Method 2 - created keystr at efs/imei/

and then

echo -n ON>/efs/imei/keystr
echo -n ON >> /efs/FactoryApp/factorymode

I had a screen that woudn't go away, annoying one ate desktop of mobile.

Also lost IMEI and fixed with a flash Param_Bin, see quote: "Recovering IMEI And Data Connection After Flashing WRONG Root Package Intended For I9300:" at:

THANKS A LOT!!! I'll pay you guys some beers!
28th February 2014, 12:07 PM |#142  
Junior Member
Thanks Meter: 0
Smile Thanks, you saved my day
Thanks a lot.

Cheers, Rob.
7th March 2014, 04:26 PM |#143  
Thanks Meter: 9
Help with galaxy reverb.
Hi, I have a galaxy reverb, M950 that I bought with missing MEID/ESN.
I am having this same problem.

Can someone help me fix it?
I don't want to use it for calling or anything. Just using it as a multimedia device.
But I want the lockscreen to work.
It is working if I install the ICS rom but not on this JB rom.

Can someone help in any way?
Since I don't have a backup of EFS I cannot restore . Is there any other way I can fix the EFS?
I have tried this method of "keystr" file. But it doesn't work(most likely because itsnot galaxy S2).

Or can someone tell me how to compare which file(s) is responsible for the working lockscreen in ICS rom so that I can do it in JB rom?
18th March 2014, 08:56 AM |#144  
Thanks Meter: 0
Question gs2 i9100 No Power Menu, No Lockscreen, Corrupt Efs
Hey I have the corrupt efs problem on my galaxy s2 i9100 there is No Power Menu, No Lockscreen, phone shuts down after just pressed power button. The imei shows null/null I have tried flashing official firmwares from sam mobile nothing helps. Is there a way to fix it ?
18th March 2014, 11:38 AM |#145  
TheCybertronian's Avatar
Senior Member
Thanks Meter: 454
This isn't the I9100's section so heck if we know. Try the s2's threads.

Sent from my SAMSUNG-SGH-I727 using Tapatalk
13th May 2014, 04:42 PM |#146  
NM's Avatar
Senior Member
Flag Paris
Thanks Meter: 42
Here is what worked for me...
Originally Posted by icenight89

If your phone shuts straight down after pressing the power button and your have no lock screen, read below for solution. Before you do any of this, please note that this was caused by the note radio, aka uclc5, and if u still have it, please remove it! Also causes include a corrupt efs partition. This guide will help to restore key files important to the operation of your phone

There are three methods available. The first and second one are recommended. If you are uncomfortable with adb and command prompt please use method one

UPDATE: This has been confirmed as working on T989!

Method 3 is only to be used if one and two fail, or if you are positive your efs is corrupt!

Original source for solution, with a few method changes by me:


1.) Use busy box installer from the market and re-install even if u have it working

2.) If step one doesn't work, install super su updater, and update it, then try step one again.

3.) Boot into cwm and dark side wipe 3x

4.) Flash rooted 2.3.5 from thread below

5.) Boot into rom and install root explorer

6). Navigate to /efs/imei/

7.) Press menu and select new file

8.) Name it "keystr" exactly as in quotes

9.) Long press keystr and select edit in text editor

10.) Type "ON" and press back, selecting save.

11.) Reboot and make sure keystr file is still present.

12.) Now u have a few options. U can flash ics back using either Odin one click (UCLA4 or UCLD2), but I don't recommend this. Flash one of the ics roms from the development section, we have great devs!

Rooted 2.3.5 zip:


1.) You must have the Samsung drivers installed for the skyrocket, available from here:

2.) Once installed, download the attached zip, its a copy of ADB with the needed file inside

3.) Unzip to any location

4.) Boot phone into cwm

5.) Go into Mounts and Storage, and select "mount /efs". Once done connect usb cable to phone and computer

6.) Open command prompt and navigate to the unzipped adb. Issue the following command "adb devices" it should list phone

7.) Now issue the following command "adb push keystr /efs/imei"

8.) Reboot phone and check presence of keystr file in /efs/imei directory with Root Explorer

Flash attached in cwm and reboot.

mahausrath and Colombiano80 for providing the efs dumps i needed
cmbrown for being a faithful tester!

After quite a long search and a lot of worries, I finally found THE solution...

how to get out of factory mode for a s4 but it worked on my N7105

- efs/factoryApp/factorymode/ouvrir avec/editeur de texte/ON
- efs/factoryApp/keystr/ouvrir avec/editeur de texte/ON
The Following User Says Thank You to NM For This Useful Post: [ View ] Gift NM Ad-Free
7th July 2014, 08:13 AM |#147  
Junior Member
Thanks Meter: 0
Can you re-upload working file again, please
3rd November 2014, 12:11 AM |#148  
WaveMaster1406's Avatar
Senior Member
Flag New York
Thanks Meter: 31
Don't forget to set permission to RWX RWX R-X if you want that works.
31st May 2015, 05:57 AM |#149  
Unhappy No lucky for me
Sorry for bring back an old discussion, but, I have no lucky with my I727.
I buy him used and with no imei already.
so, I flash different roms, do everything I found on the web... (except the method 1 in this post, 'cause the 2.3.5 file is missing)
I think the board has a problem.
today I have a cm9 running in device, with phil's recovery, I don't mind to flash the retail rom or wipe everything.
11th February 2017, 01:23 PM |#150  
Junior Member
Thanks Meter: 0
Screen lock koi b nahi lag raha no swipe. Patteren. Pin lock samsung gt-n 7000
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes