FORUMS
Remove All Ads from XDA

[GUIDE] Set up ADB and Fastboot on a Mac easily (With Screenshots!)

5,727 posts
Thanks Meter: 2,843
 
By AshtonTS, Senior Member on 2nd October 2012, 11:37 PM
Post Reply Email Thread
23rd June 2015, 07:57 AM |#181  
Junior Member
Thanks Meter: 2
 
More
Thanks for this post
The Following User Says Thank You to Benjaminrice For This Useful Post: [ View ] Gift Benjaminrice Ad-Free
29th June 2015, 11:01 PM |#182  
v8dreaming's Avatar
Senior Member
N. Las Vegas
Thanks Meter: 242
 
More
deleted
3rd July 2015, 02:10 PM |#183  
r0ger's Avatar
Junior Member
Flag Milan
Thanks Meter: 5
 
More
If you start flashing your firmware downloading only adb and fastboot please be sure to download the latest version otherwise you may experiments errors like the one below

# fastboot flash system image-shamu-lmy47z/system.img
< waiting for device >
sending 'system' (1737280 KB)...
(bootloader) Data size exceeds download buffer

Just in case... to flash Android 5.1.1 on a Nexus 6 I succesfully used the version below attached
Attached Files
File Type: zip 1.0.29-adb-fastboot.zip - [Click for QR Code] (641.2 KB, 648 views)
The Following 4 Users Say Thank You to r0ger For This Useful Post: [ View ] Gift r0ger Ad-Free
13th August 2015, 06:10 PM |#184  
Member
Flag Lauwe
Thanks Meter: 9
 
Donate to Me
More
thanks this helped allot but to instal i used this: http://htc-one.****************/how-t...c-one-0151178/
seems allot easier i was mainly here for the usage of the commands where i had to go in terminal n stuff, the shortcut is realy nice!!
i used to have windows until 3 days and i'm still setting up everything on my new macbook pro 2015 really like the OS! i am an experienced windows user so i understand how computers work if u have any advance mac tips please let me know in PM. Thanks for this tutorial, learning everyday!
19th August 2015, 12:12 AM |#185  
Senior Member
Thanks Meter: 12
 
More
Hi all,

Just trying to do this but my device says unauthorised. what do I need to do?

Thanks


edit: okay I got it to work by unplugging and plugging a few times.

I thought this would make my device appear as a storage device in Finder but this is not so... am i misunderstanding the use of this?
26th September 2015, 12:28 PM |#186  
Senior Member
Flag Terni, Italy
Thanks Meter: 89
 
More
Hallo everybody, i have some problems. I always used my adb-fatboot folder with nexus 5 without any issue. Today, using the same folder, i unlocked my Oneplus two bootloader but when i try to flash twrp using as usual "fastboot flash recovery recovery.img" command i have always this message: error cannot load "recovery.img". What's wrong with this?

edit: solved, dragged and dropped file directly in terminal window
The Following User Says Thank You to follettoverde For This Useful Post: [ View ] Gift follettoverde Ad-Free
4th October 2015, 08:20 PM |#187  
Junior Member
Thanks Meter: 1
 
More
Thank you for the GUIDE, you have saved us from a lot of mess
19th October 2015, 03:27 AM |#188  
Senior Member
Thanks Meter: 25
 
More
Wow, this was incredible. Thank you so much!
18th December 2015, 03:15 PM |#189  
vladworks's Avatar
Member
Thanks Meter: 0
 
More
Hi.

I am using a Mac ( el capitan )...I have installed the Android Studio and adb looks installed correct.

When running command ./adb version it gives:
Android Debug Bridge version 1.0.29

When I run ./adb devices however I get:
adb server is out of date. killing...
* daemon started successfully *
List of devices attached

How can I solve this so I can root?
20th December 2015, 04:15 PM |#190  
Member
Thanks Meter: 7
 
More
Hello, maybe someone can enlighten me.
How can I get the adb and fastboot files updated? I mean, I have a version on the desktop right now which I used last summer for my N5, but I ain't sure they're fine with the OP2 I got now (or for the N5 right now, if I still had it). Shall I download the whole Android SDK package and then get out the two things? How do I do so?
Thank you.
6th February 2016, 06:53 PM |#191  
Junior Member
Thanks Meter: 0
 
More
I have followed all of the steps but am having trouble retrieving the device's serial number in terminal. I believe it may have something to do with the fact that I cannot enable usb debugging because my device has no operating system. Is there a way to get around this or a way to turn it on from recovery mode?

Thanks in advance!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes