Remove All Ads from XDA

Lenovo IdeaPhone S920

40 posts
Thanks Meter: 15
By saturn_frak, Member on 25th June 2013, 09:14 PM
Post Reply Email Thread
7th March 2015, 10:47 AM |#251  
jobzsparrow's Avatar
Senior Member
Thanks Meter: 20
Originally Posted by Kagemazu

Hello everyone I have problem with viper4android. My phone is Lenovo S920 running on android 4.4.2 and then I tried to install viper4a, install the driver and reboot. But unfortunately it won't work and the viper4a asking for installing the driver again even I already push the viper4a into /system. Many way I tried to install the viper4a but fail and my college said that I need to change SELinux so I change it and nothing happen, it's same.

Even I already edit system/etc/audio.effect.conf and also push the lib viper4a into system/lib/soundfx and again nothing change. My phone is already root, busybox ready, SELinux set to permissive and it seem no hope installing viper4a on my phone...

anybody please help me to fix this problem... My ears have been very comfortable with viper4a and I would not replace it with another sound engine.

I want to provide ss from my phone but I can not because of this is my new post in here...

just download and install ViPER4Android_FX_A4.x.apk in ViPER4Android FX

after ViPER4Android installed , you can move it into system app (unnecessary) then install Driver

it should work
8th March 2015, 09:19 AM |#252  
Junior Member
Thanks Meter: 0
Originally Posted by jobzsparrow

just download and install ViPER4Android_FX_A4.x.apk in [skipped]

after ViPER4Android installed , you can move it into system app (unnecessary) then install Driver

it should work

yeah of course it should work but nothing happen when I do that

The v4a it's already pushed into the system and take no effect at all. I try to put the driver manually, edit audio_effects.conf and again take no effect. There is no option menu in setting->default audio in my device. Everything seems going hard to put v4a on my phone

it's look like my phone doesn't support v4a and I don't know why.....
20th March 2015, 05:18 PM |#253  
Junior Member
Thanks Meter: 0
Smile Cyanogen(latest) ROM for Lenovo s920
I want to install latest Cyanogen ROM for s920. I tried to google but its so confusing to find latest rom from cyanogen.

Android Version - 4.4.2
Baseband version - S920.ROW.V105, 2015/01/19
Build Number - S920_ROW_8G_S221_150119

I am going to follow these steps to root

and to install CWM recovery via fastboot? ( I installed cwm on my Dell Venue thr fastboot hope its possible on lenovo too?)

and waiting for stable and lastest ROM specially for KitKat or lollipop

Thanks friends awaiting replies desperately
17th July 2015, 12:37 PM |#254  
Rini94's Avatar
Thanks Meter: 4
Donate to Me
So I tried two custom MIUI roms and I am having the same storage problem from each of them. The phone won't detect the built in storage of my phone. I am using Lenovo S920 (4 gb) with Android version 4.2.1. I flashed the MIUI V6 5.2.26 (kitkat) from And this rom takes my 8 gb SD card as the built in storage(sdcard0). My phone used to have around 1 gb as internal memory and 1 gb for system rom and 2 gb for built in storage whic was previously the sdcard0. Now the entire 2 gb of built in storage is missing.

I thought the problem was with the rom, so I installed MIUI V6 5.0.1 (kitkat) from, but I am still having the same problem.

Does anyone know how to get the 2 gb back? I tried root explorer and es explorer, but according to those, the 8 gb memory card storage is my sdcard0 storage and there's nothing in sdcard1. :-/
14th August 2015, 04:28 PM |#255  
Thanks Meter: 0
Originally Posted by ghoul3003

Thanx a lot mate.
I buy my phone s920 from taiwan and now instal the rom no more taiwan china and more faster.
Thanx a lot again mate.

I have lenovo s920 row model I have flash ROM successfully also its working but problem is when i select the reboot option by pressing the power button its screen of but again on and just vibrating n keep nothing displaying so what can I do?
4th September 2015, 08:40 AM |#256  
Junior Member
Thanks Meter: 0
Thumbs up
just go in settings>about phone>system update.....&then just update it

for rooting phone just download KINGROOT (download it by searching kingroot apk xda on google).follow the steps & ur phone would b rooted ..enjoy
4th September 2015, 02:33 PM |#257  
Thanks Meter: 0
But after downloading updation pack its take to restart the device but when its take for restart. But not successfully so its show the updation fail.
11th July 2019, 05:11 PM |#258  
coolkillermax's Avatar
Senior Member
Flag Malaysia
Thanks Meter: 122
Lenovo s920 has nougat MIUI 9 ROM
Hi All,

Per below link is hard to believe that s920 Very Old device still have nougat ROM ?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes