Remove All Ads from XDA

[GUIDE] Easiest Way to Root & Flash Recovery On your Xolo Q800

922 posts
Thanks Meter: 1,777
Post Reply Email Thread
Easiest way to root and flash recovery on your XOLO device

(This method can be used on most mediatek devices Q1000, Q700i,Q700,Q800 or Q600 but RECOVERY will differ for each device)

Step by Step explaination below:

STEP 1: Download Latest Framaroot APK from this link

STEP 2: Install the App and Launch it

STEP 3: open app and select Super SU from dropdown menu, Select boromir now n reboot your phone.

STEP 4: Download The Recovery of Your Choice
I Prefer TWRP myself
TWRP for Xolo Q800-link
CWM for Xolo Q800-link

STEP 5: Locate recovery.img and extract from rar file (you can use es file explorer or easy unrar lite for that)

STEP 6: Now place recovery.img in root of your SD card

STEP 7: Download Mobile Uncle tools from play store
Link Here

STEP 8 : Open Mobile Uncle tools and select Recovery Update (as in pic below)

STEP 9:Following Screen will pop up showing recovery.img, select recovery.img n select ok, then reboot into recovery n viola your phone is rooted n you flashed recovery too

CONGRATULATIONS!!! you have successfully rooted your XOLO Q800

Alephzain - for Framaroot
njava- for Mobile Uncle Tools
Back37 - For Recovery For Xolo Q800
The Following 3 Users Say Thank You to bgos10 For This Useful Post: [ View ] Gift bgos10 Ad-Free
1st June 2014, 05:04 PM |#2  
Abhith's Avatar
Flag Cochin
Thanks Meter: 13
Thanks, all the above worked perfectly on my Xolo Q800 X-Edition.

Sent from my C2305 using Tapatalk
3rd July 2014, 06:09 PM |#3  
Junior Member
Thanks Meter: 1
need TWRP for xolo q800-X edition
will this work on xolo q800-X edition?
9th September 2015, 10:43 AM |#4  
Junior Member
Thanks Meter: 0
unable to rootflash my xolo q800
as per following steps when i tap on recovery image in mobile uncle app warning massage flashed as please root ur android first
plz help to resolve
30th September 2015, 07:52 PM |#5  
Junior Member
Thanks Meter: 0
Xolo Q800 Variety Problem
I tried to install custom recovery and custom rom and when I tried to install in my pc its showing installed recovery and custom rom and also done a full flash of stock rom.

After booting the same rom appears and same notifications appears.

I tried to reset the from settings and tried to reset from android stock recovery, After booting the same rom appears and same notifications appears.

Please help me asap.
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes