Remove All Ads from XDA
Honor 9 Lite

[Q] MT6589 Trying to unbrick iPhone i5s clone but cannot keep the phone connected

37 posts
Thanks Meter: 3
By jimrin, Member on 3rd January 2014, 08:36 PM
Post Reply Email Thread
I have a (supposed) MT6589 iPhone i5s clone which I managed to brick. I tried to use the instructions here to use the SP Flash Tool to unbrick it, but the first problem I have is with getting my Windows 7 (32 bit) computer to recognize the phone. I installed the MediaTek MT65xx Preloader VCOM driver and it connects for a second. I can see the device connected as a COM device, but it only stays connected for a second and then disconnects. (This is independent of whether I am running the SP Flash Tool or not.)

Is this a symptom of a bad driver? The other problem with trying to follow the instructions is that it says to remove the battery, but this copy is a 1:1 of the iPhone so it is not intended to be opened up. I tried to discharge the battery completely, but when I plug the device in, there seems to be no response (ie, Windows doesn't do anything). At some point, there seems to be some charge in the battery because of constantly plugging in the USB cable, and at that point, is when the device is recognized but is quickly disconnected.

Anyone happen to know what I am doing wrong?

So in general, I am first interested in:
  • Why is the device connecting properly (I assume) being recognized as MediaTek Preloader VCOM, then disconnecting in about a second?
  • Is it related to not being able to disconnect the battery?
  • In theory, wouldn't a dead battery be the same as disconnecting the battery?
  • When battery is dead, nothing happens when I connect the phone to my PC. This seems odd since I am supposed to be able to connect to the PC without any battery... What is the difference?
  • Per instructions, I've been pressing the + volume button when connecting, but I seem to get similar results no matter if I press + or not.
  • Should I be loading any other drivers besides the MediaTek Preloader drivers?


PS. I've decided to open up the phone using a video found on YouTube, and found that the battery is soldered, so I am not so motivated in trying to disconnect the battery if possible.

Update: OK, the problem I likely had with the phone is that since the phone was in a type of "boot loop", I couldn't actually tell it was on or not... And plugging in the cable only worked if the phone is off. Once I made sure the phone was dead due to battery dying and made sure I did not turn the phone on, I could connect, let the battery charge long enough for the phone to respond to the PC, and then it was recognized by SP Flash Tool. However, seems I may have tried flashing something incompatible as the phone is not responding. I'll likely need to write another post once I can find the symptoms of what is going on.
7th October 2015, 10:19 PM |#2  
Junior Member
Thanks Meter: 0
Try hardware preloader MOD which means test point on the phone board; by soldering one to GND and another point on the board (connecting points are clear on the board), this will stop connecting and disconnecting phenomenon
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes