FORUMS
Remove All Ads from XDA

[Q] Can't Establish A Connection SOLVED !!

71 posts
Thanks Meter: 4
 
By 2easy4you, Member on 5th January 2013, 01:28 PM
Post Reply Email Thread
20th May 2014, 03:32 PM |#21  
Junior Member
Thanks Meter: 0
 
More
Thanks man your the best
Quote:
Originally Posted by viveknayyar

here's what you need to do.

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (i used root explorer and did this on my samsung galaxy tab n8000).

In 'etc' folder, locate the file called hosts.

Touch/press and hold the icon of the file to get its context menu and open the file in text editor.

In the file, there will be one ip address to the localhost, i.e. 127.0.0.1. Leave this as it is.

There will be a second ip address which may vary depending upon your region or country. Put a # in front of it. (eg. #245.45.14.14). This will mark this entry as a comment and the device won't read it.

(i would suggest that you backup 'hosts' file before making any changes. In my case, a 'hosts.bak' file was automatically created when i saved the file after editing.)

save the file and reboot your device.

This should resolve the issue.

thank you very much friend you realy save my phone many many thanks...
 
 
12th June 2014, 02:40 AM |#22  
Junior Member
Thanks Meter: 1
 
More
Fix Google couldn't establish a connection
You can download root explorer and delete hostfile if rooted already if not like I was root with this vroot
Then delete hostfile download vroot frome the developers sight just search vroot download on google its the first I ink its in chineese but some words are in english so you can understand it worked for me today when I couldnt fix it
The Following User Says Thank You to xavier1728 For This Useful Post: [ View ] Gift xavier1728 Ad-Free
1st August 2014, 09:53 AM |#23  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by VivekNayyar

Here's what you need to do.

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (I used Root Explorer and did this on my Samsung Galaxy Tab N8000).

In 'etc' folder, locate the file called hosts.

Touch/press and hold the icon of the file to get its context menu and open the file in text editor.

In the file, there will be one IP address to the localhost, i.e. 127.0.0.1. Leave this as it is.

There will be a second IP address which may vary depending upon your region or country. Put a # in front of it. (eg. #245.45.14.14). This will mark this entry as a comment and the device won't read it.

(I would suggest that you backup 'hosts' file before making any changes. In my case, a 'hosts.bak' file was automatically created when I saved the file after editing.)

Save the file and reboot your device.

This should resolve the issue.

........
thanksssssssssssss budyyyyyyyyyyyyyyyyy.....thanksssssssssss
18th September 2014, 04:46 PM |#24  
Bukchoo's Avatar
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by lopesamit

Just install adfree.. Update the hostname and its done..
Worked for me
Worth a try..

Your trick worked for me !!
28th March 2015, 05:21 AM |#25  
Junior Member
Thanks Meter: 0
 
More
So many IP's
Quote:
Originally Posted by VivekNayyar

Here's what you need to do.

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (I used Root Explorer and did this on my Samsung Galaxy Tab N8000).

In 'etc' folder, locate the file called hosts.

Touch/press and hold the icon of the file to get its context menu and open the file in text editor.

In the file, there will be one IP address to the localhost, i.e. 127.0.0.1. Leave this as it is.

There will be a second IP address which may vary depending upon your region or country. Put a # in front of it. (eg. #245.45.14.14). This will mark this entry as a comment and the device won't read it.

(I would suggest that you backup 'hosts' file before making any changes. In my case, a 'hosts.bak' file was automatically created when I saved the file after editing.)

Save the file and reboot your device.

This should resolve the issue.

I've looked everywhere for a solution, I thought this one might help. So I went to my host file and there's so many IP's its not even funny. Do I just put a # on all of them? I so desperately need help. Using Nexs 5 4.4.4.
12th April 2015, 01:27 PM |#26  
Junior Member
Thanks Meter: 0
 
More
Thumbs up another approach
i tried this method for my nokia x2 dual sim but didnt work, rather, i did this so if yours do not work out by applying this method, you can try this approach

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (I used Root Explorer and did this on my Nokia X2 dual sim).

In 'etc' folder, locate the file called hosts.

Just delete that file and since the phone automatically recreates its repairable missing files, it will create another one once you reboot your phone.

(I would suggest that you backup 'hosts' file before making any changes. In my case, i copied the file and pasted it onto my sd card before deleting it; thus in case, it didnt work out, coz you sure wouldn want to risk soft bricking your phone or damaging its internet acces)

Then just reboot your device. It should work

This should resolve the issue. [/QUOTE]
24th June 2015, 01:38 AM |#27  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by VivekNayyar

Here's what you need to do.

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (I used Root Explorer and did this on my Samsung Galaxy Tab N8000).

In 'etc' folder, locate the file called hosts.

Touch/press and hold the icon of the file to get its context menu and open the file in text editor.

In the file, there will be one IP address to the localhost, i.e. 127.0.0.1. Leave this as it is.

There will be a second IP address which may vary depending upon your region or country. Put a # in front of it. (eg. #245.45.14.14). This will mark this entry as a comment and the device won't read it.

(I would suggest that you backup 'hosts' file before making any changes. In my case, a 'hosts.bak' file was automatically created when I saved the file after editing.)

Save the file and reboot your device.

This should resolve the issue.

thanx alot you are a life saver
19th October 2015, 09:51 AM |#28  
Junior Member
Flag Aurangabad
Thanks Meter: 2
 
Donate to Me
More
Solution for the Problem
Hey Guys... Just Do one thing is Set the Right Date &Time.... Its just because of SSL error because of Wrong Date & Time as its work with SSL Certificate.... Just check it... It will be done....
The Following User Says Thank You to saiyyedfardeen For This Useful Post: [ View ] Gift saiyyedfardeen Ad-Free
6th December 2015, 01:50 PM |#29  
Mirhawk's Avatar
Senior Member
Thanks Meter: 621
 
More
Quote:
Originally Posted by saiyyedfardeen

Hey Guys... Just Do one thing is Set the Right Date &Time.... Its just because of SSL error because of Wrong Date & Time as its work with SSL Certificate.... Just check it... It will be done....

Thanks a lot buddy! Saved Me a lot of hassle!!
6th December 2015, 06:54 PM |#30  
Junior Member
Flag Aurangabad
Thanks Meter: 2
 
Donate to Me
More
My pleasure bro....
19th January 2016, 08:35 PM |#31  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by VivekNayyar

Here's what you need to do.

Assuming that you have already rooted your device, use any file explorer app and go to 'etc' folder of your device. (I used Root Explorer and did this on my Samsung Galaxy Tab N8000).

In 'etc' folder, locate the file called hosts.

Touch/press and hold the icon of the file to get its context menu and open the file in text editor.

In the file, there will be one IP address to the localhost, i.e. 127.0.0.1. Leave this as it is.

There will be a second IP address which may vary depending upon your region or country. Put a # in front of it. (eg. #245.45.14.14). This will mark this entry as a comment and the device won't read it.

(I would suggest that you backup 'hosts' file before making any changes. In my case, a 'hosts.bak' file was automatically created when I saved the file after editing.)

Save the file and reboot your device.

This should resolve the issue.

I have been going nuts trying to find a solution to this issue and thought that this would be it.
However, for some strange reason, I get an "error occurs during saving" message.
I also tried the alternative methods of checking the date & time, as well as deleting the 'hosts' file. But it says that it can not be deleted.
Anybody familiar with this?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes