Remove All Ads from XDA

Zopo C2 brick, please help.

37 posts
Thanks Meter: 3
By donaspl, Member on 29th April 2014, 02:15 PM
Post Reply Email Thread

I have a phone ZOPO C2 VER B. Phone turned off and do not ever want to turn on. It stopped responding to the charger, do not give any sign of life.
When connected to computer detects the phone, installs the drivers, the SP FLASH TOOL it detects. I pulled a few ROMs and I can not upload any ROM. It is always like this: It comes to 100% red belt and that's it. No error. The phone is detected as the MTK PORT, sometimes after reaching the 100% change in VCOM MediaTek USB DA. Here I give a link to the video where you can see how it looks.
I tried to upload separately preloader, recovery boot. Always the same ending. I tried with the battery in the phone, without the battery, hold Vloume - + Power, etc. Nothing gives all the time is the same.
Use three other PC to try. I have one more phone Zopo and on the same computer and the same driver is dowload rom with SFP without problems.

Phone is brick or can fix this?

Sorry for my english is bad
11th December 2015, 09:53 PM |#2  
Junior Member
Thanks Meter: 0
I am having the same problem, until now could not solve.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes