Remove All Ads from XDA
Honor 9 Lite

[Q] Nexus 7 hangs at "Google", can't enter Recovery

43 posts
Thanks Meter: 4
By thisisjjd, Member on 11th February 2014, 11:13 PM
Post Reply Email Thread
21st September 2015, 05:32 AM |#81  
Junior Member
Thanks Meter: 2
I... think I am on the same list I don't understand what is going on here. It's all the more strange because the previous Nexus 7 that I bought in 2013 was fine with rooting and flashing. I had to get a new one because I dropped it and the screen wouldn't function. I bought one off of Ebay that looks to be made in 2015, according to the barcode.

So the issue with mine is...

It came with 5.0.2, and after turning it on, it installed a bunch of updates that eventually got me to 5.1.1. Cool beans. But for some off reason, the tablet would freeze randomly and reboot. I thought maybe something was wrong with the OS, so I tried to restore it to factory settings. Still got random reboots. So I thought I would try to flash back to KitKat. Downloaded the image from Google's list of factory images, but it would never get past the Google screen. I then redownloaded 5.0.2 and that seemed to get it to work. Updated again to 5.1.1. and the tablet ran fine for about a day.

Now today...I left it to charge. About an hour later, I checked the tablet and it was again, stuck on the Google screen. I never turned it off or anything, so I don't know what happened. Every time I turn it off, it would just turn right back on. I tried to go to recover mode, but like the OP, it just hangs on the Google screen, never gets to the Android lying on its back. Tried to turn it off again, nope, keeps on turning on.

Since it wouldn't go back to recovery mode, I left it at the bootloader, and tried to flash 5.0.2 and 5.1.1 using BOTH WUG's Nexus Root Toolkit, and just a regular adb cmd window. There are no errors in the logs, but neither one gets me past the Google screen.

So... on a scale of 1 to 10, how screwed am I?
21st September 2015, 06:28 PM |#82  
Divine_Madcat's Avatar
Forum Moderator
Flag USA
Thanks Meter: 2,634
As far as anyone seems to be able to tel, a 10. I dont know how crazy people have went with diagnosis, but it appears to be an issue with the EMMC corrupting/dying for one reason. When it happens, your only choice is a new motherboard, and cross your fingers that it doesn't happen again.
23rd September 2015, 06:46 PM |#83  
Senior Member
Thanks Meter: 107
A couple of days ago I posted some questions regarding this bricking issue in another thread, especially regarding whether anybody knows how the prevent a Nexus 7 from bricking (as there are obviously enough people around here who's devices are still running fine).

As there were no answers here are my own conclusions:
You need to avoid any official OTAs: It's obvious when googling this (and checking e.g. twitter (#nexus7bricked) that over the last weeks there have been a lot of new complaints about bricked devices - this coincides with the recent security OTAs for 5.1.1 that Google has rolled out. OTAs like these will now be rolled out monthly, which means we'll see more bricked Nexus 7s every single month.

So one could come to the conclusion that those bricks are caused directly by the OTAs. BUT: A lot of people report that after an OTA they were operating their device normally - until their devices "spontaneously" bricked. I have however not read any reports of custom ROM users who have experienced these issues; maybe I missed those posts or those people just didn't mention it. Anyway, I've got the impression that this is only caused by the official firmware and especially in relation to applying official OTAs.

Therefore, if you don't want to brick your device again: Don't use the official stock firmware at all. If it's currently still on an official stock firmware: under any circumstances, don't apply any OTA, ever, at all. Only flash custom ROMs, and to be save, flash a custom ROM and kernel that is F2FS capable, with first formatting everything - even /system (and /cache) - with F2FS. Once you have done that, you might want to use trim sometimes (yes, F2FS takes care of trimming, however it is still possible to manually trim F2FS partitions nowadays with the latest F2FS implementations and it *will* have an effect). There's a proper trimming app out now that doesn't want your money nor any crazy permissions as it was the case with the only available trimming app in the past. You can find it here: (root obviously required).

Unfortunately people mostly focus on F2FS support only for the old Nexus 7 2012 tablet which suffers from degrading storage anyway, for which F2FS is merely a damage control measure so that you can keep using it for a while longer until the device will permanently be close to unusable.
3rd October 2015, 08:55 AM |#84  
Que_Ball's Avatar
Junior Member
Flag Edmonton
Thanks Meter: 1
Originally Posted by Haggster66

I have to say I'm surprised that there are still unbricked Nexus 7s around: Has the issue ever occurred after flashing custom ROMs or is it only happening when updating via stock OTAs?!

I have checked all Q&A threads that might be related but haven't found any official brick avoidance strategy in order to prevent this from happening.

Buy a Tablet with higher quality flash controller and flash memory is solution. Premature wear on flash chip exhaust write cycles leading to failure. If bug in memory controller firmware they may have fixed it in one of the 5.1.x builds but your chips are already damaged if you ran previous build or that firmware failed to update and it is still running buggy wear levelling routine.

Smell a lawsuit if Asus does not keep fixing those affected for free. Mine was fixed free out of warranty. Had to dispute the invoice they tried to stick me with. Only cost me shipping.

Sent from my SM-G925W8 using XDA Premium HD app
5th December 2015, 03:33 AM |#85  
Junior Member
Thanks Meter: 0
Fix for hanging at "google"
I found it on another site. Power down and then back on. When it gets to the google screen tap the back of the device a bunch and it will move on and continue to boot. I've had it going for about 3 hrs now and a few reboots and so far it is working normally.
14th December 2015, 04:03 AM |#86  
Got one as a gift from employer, completely stock. Same issue as OP.
Google logo only. Even from recovery, won't start, or enter recovery.
No hope?
18th January 2016, 08:11 PM |#87  
Tmzdroid's Avatar
Senior Member
Flag Doncaster
Thanks Meter: 35
I recently traded in my old 2012 Nexus for a 2013 which wouldn't boot up , had lots of random reboots and a very dodgy touchscreen. I took the back off and taped down the 2 ribbon cables to the battery. It sort - of worked but it was never 100%. I now have a replacement and it feels like a totally different tablet. It feels better made and works perfectly. Definitely hardware issues with too many 2013 Nexus 7s which Google have chosen to ignore.
31st March 2017, 06:41 PM |#88  
Senior Member
Thanks Meter: 194
Resurrecting an old topic, I suppose . . . I replaced the display for one of our stock Nexus 7 (2nd generation) tablets recently and it was great for a couple of days, then got the dreaded Google logo hang on a reboot after battery was accidentally drained.

I have replaced the display on our other N7 tablet and it is still working fine, so I am not sure if something changed in my process this time around. Opened it up again and nothing seems to be loose, so not sure of the issue.

This video seems to indicate possible connection issues or it's simply a normal bootup sequence being offered as a miracle cure:

Any clues/updates to resolve this bootup hang since a year ago, perhaps?

- ooofest
10th April 2017, 08:04 AM |#89  
Junior Member
Flag Alexandria
Thanks Meter: 1
Originally Posted by ooofest

Any clues/updates to resolve this bootup hang since a year ago, perhaps?

- ooofest

I have had this boot hang with all the symptoms as everyone else happen 3 times to my Nexus 7 flo. The first time (I was not on stock ROM) I was able to resolve it by doing multiple back to back soft resets. (something like 10 in a row) Also this was on Christmas eve of 2016. The second time (happened a month later) ((Still not on stock ROM)) I was able to somehow get everything back working by banging "gently" on the back then using WugFresh and flashing back to stock Lollipop. Third time, which I assume was the charm, happened about 2 days ago and have not figured out any way to get it back up. Funny part is it time was the first time I had run into the problem while running a stock ROM. Go figure it is the one time I can't find a work around. It is honestly the only time I had ever ran a stock ROM on the Nexus 7 flo since I bought it in 2013.

I guess in short my point is I do not believe there has been a true solution to the issue. Sorry
The Following User Says Thank You to design.maddie For This Useful Post: [ View ] Gift design.maddie Ad-Free
Post Reply Subscribe to Thread

boot, hang, recovery, stuck

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes